MAYA Animazione Tutorial n. 8

Tutorial Otto -
Animazione con Maya

Introduzione

Prepariamoci per la lezione

Per poter studiare queste lezioni € necessario impostare alcune preferenze
tramite i vari menu.

1
Selezionate Window > Settings/Preferences > Preferences.
Cliccate sulla categoria Settings e impostate |'opzione Time a Film (24
fps) in modo che la vostra animazione verra eseguita con una frequenza
di 24 frames al secondo;cliccate su Save.

2

Selezionate il menu Animation
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Lezione 1: Keyframing e Graph Editor

Nel momento in cui settiamo un keyframe (o key), assegniamo un valore ad un
determinato oggetto in un determinato momento.

Assegnando differenti keys in momenti differenti e con differenti valori, Maya
genera i valori degli attributi nella linea temporale relativa al keyframing.

In queste lezioni vedremo come, tramite la tecnica di keyframing appunto,
riusciremo a far passare una pallina da tennis sopra la rete e quindi sul terreno.

Vedremo anche come con il Graph Editor modificheremo I'andamento del
movimento della pallina.
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Apriamo la scena e impostiamo il range di playback

In questa lezione lavoreremo con una scena gia creata e pronta per essere
utilizzata.

1
Aprite la scena Keyframing.mb.
La pallina da tennis & posizionata sull'asse delle X, vicino alla parte
estrema del terreno.
Per animare la pallina & necessario creare differenti keys in modo da
avere il playback range.
Il playback range attualmente € da 1 a 24; con un default rate di 24
frames per secondo, la scena potra essere animata al massimo per un
secondo e diventa quindi necessario allungare il playback range.
Time Slider Flayback Controls
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La Time Slider visualizza il playback range e le keys settate per I'oggetto
selezionato.
Le keys sono visualizzate come una linea rossa, mentre il box alla destra
della Time Slider ci da la possibilita di impostare il frame corrente (time)
dell'animazione.
Il Playback Controls controlla il playback dell'animazione.(classici pulsanti
del walkman!)
Il bottone relativo alle Animation Preferences visualizza una finestra per
definire le preferenze relative all'animazione, come ad esempio la velocita
di playback.
Il Range Slider controlla il range di frames avviati quando clicchiamo sul
bottone play.
2

Nel box Playback End Time (guardate la figura sopra), inserite 72.

Con un playback range da 1 a 72, potremo creare un'animazione di tre
secondi! (72 frames diviso 24 frames per secondo corrispondono a 3
secondi di animazione)
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Impostare la beginning e la ending key

1
Clicchiamo sul rewind button in modo da posizionarsi all'inizio del
playback range;in questo modo ci troveremo al frame 1.
2
Selezioniamo la pallina, quindi Animate > Set Key.
Abbiamo appena impostato un key al frame 1 per tutti gli attributi di
trasformazione della pallina.
Se notate bene al frame 1 nella Time Slider, compare un marker rosso,
detto anche tick. Il tick indica il punto in cui € stato creato un key frame.
3
Posizionatevi al frame 72. (tramite la Time Slider)
4
Con lo strumento Move, spostate I'asse delle X della pallina in modo da
posizionare la pallina sulla parte destra del terreno.
........ _:_-:_ﬂ_*b‘
5
Definite un key al frame 72. (premendo s.)
6

Andate all'inizio dell'animazione e avviatelal
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Aggiungere keys intermediarie

Per far si che la pallina passi dall'altra parte della rete, bisogna prima
posizionare la pallina sopra la rete e impostare un key frame.

1
Posizionatevi al frame 33 (pit 0 meno).
2
Con lo strumento Move spostate I'asse Y della pallina, in modo da
posizionarla come mostrato in figura.(potete utilizzare la visuale front o
side per capire meglio lo spostamento effettuato)
~
3
Impostate un key frame. (premendo s.)
4

Avviate I'animazione.

Noterete come la pallina da tennis passera sopra la rete e quindi cadra
sul terreno dopo aver compiuto un movimento ad arco, movimento
dovuto alle 3 key frames create fino a questo momento.

Per le prime animazioni € meglio testare la stessa ogni volta che
impostiamo un key frame, in modo da comprendere quello che stiamo
facendo e l'evolversi dell'animazione.
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Aggiungere un key frame per far rimbalzare la pallina

1
Posizionatevi al frame 50;la pallina si trova nella parte destra della rete,
ad un'altezza media.
2
Spostate la pallina in modo che venga posizionata sul terreno.
3
Impostate un key frame.
4
Andate al frame 60.
5

Spostate la pallina verso alto, ma non troppo, sicuramente non piu di
quanto sia l'altezza della rete.
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Impostate un key frame;avviando I'animazione, la pallina passa sopra la
rete e rimbalza dall'altra parte.

Nel caso aveste un computer prestante, noterete che I'animazione ¢ fin
troppo veloce;di default Maya riproduce I'animazione al massimo della
velocita.

Per poter riprodurre I'animazione in base all'attuale film rate, cliccate su
Animation Preferences.

Nella Playback section modificate Playback Speed da Play Every Frame a
Real-time (24 fps).

Cliccate su Save;da adesso quando avviate I'animazione, verra riprodotta
esattamente nella modalita 24 frames per secondo.

Non preoccupatevi troppo della qualita dell'animazione, in quanto non
stiamo facendo alcun render, ma solo riproducendola tramite gli
strumenti offerti da Maya;nel caso voleste riprodurre I'animazione con
una qualita maggiormente fedele, ricorrete a Window > Playblast.
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Tutorial Otto -
Animazione con Maya

Introduzione

Migliorare il movimento tramite il Graph Editor

1
Con la pallina selezionata, cliccate su Window > Animation
Editors > Graph Editor.

Il Graph E ditor
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Il Graph Editor visualizza una serie di animation curves (curve di
animazione), una per ogni keyframe relativo alla pallina; piu
precisamente, vengono visualizzati gli attributi del transform node della
pallina.

Ogni curva € una rappresentazione grafica di come cambia |'attributo
durante lI'animazione;la colonna dei numeri sulla sinistra indica i valori
dell'attributo, mentre la colonna di numeri in basso indica i frames.
Ogni puntino nero sopra una curva, rappresenta un key frame.
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Selezionate la Translate X e la Translate Y, in modo che all'interno del
Graph Editor siano evidenziate solo queste due animation curves;in
questo modo semplifichiamo la rappresentazione delle curve e quindi la
nostra prossima modifica.

Per centrare la visualizzazione delle animation curves, selezionate
View > Frame Selection (nella finestra Graph Editor).
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La curva verde rappresenta la Translate Y, mentre la curva rossa
rappresenta la Translate X; il colore di ogni curva indica il nome del
proprio attributo.

Se e la prima volta che utilizzate un Graph Editor, la relazione fra
I'andamento delle curve e I'animazione potrebbe apparirvi difficoltosa da
comprendere, ma il tutto risultera piu chiaro con il tempo e la pratica.
Esaminiamo la Translate X (rossa);la pallina si muove orizzontalmente in
maniera costante nel tempo.

La Translate Y, invece, indica che la pallina si muove verso |'alto fino al
frame 33, quindi scende velocemente fino al frame 50 e infine sale e
scende nuovamente fino al frame 72.

Notate la morbidezza della curva dal frame 50 al frame 60;questo spiega
il motivo per cui la pallina dopo il rimbalzo si muove comunque in
maniera troppo 'delicata’ rispetto a quello che sarebbe un movimento
naturale in seguito all'impatto con il terreno.

Piuttosto che una curva tonda, dovremo crearne una ad angolo e questa
modifica puo essere fatta solo tramite il Graph Editor.
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Selezionate il puntino nero sulla curva Translate Y (verde) al frame
50;compariranno delle tangenti.

Tramite le maniglie per le tangenti € possibile regolare e controllare la
curvatura in prossimita del puntino nero selezionato. (chiamato key
point)

Tramite Move e il tasto centrale del mouse, potete spostare un key point.
E' anche possibile inserire un valore da tastiera, utilizzando I'apposito box
sopra l'area del Graph Editor.

Tramite Move e il tasto centrale del mouse, potete trascinare le maniglie
delle tangenti e modificare il tipo di curva.
(con shift premuto € anche possibile vincolare il movimento del mouse)

Tramite Scale e il tasto centrale del mouse, potete scalare i key points
selezionati avvicinandoli o allontanandoli.

Tramite il Tangent Menu del Graph Editor € possibile modificare il tipo di
curva;vediamo come.
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Dal Graph Editor, selezionate Tangents > Linear;in questo modo la curva
relativa al key point verra modificata da rotonda ad angolata.
In pratica abbiamo modificato l'interpolazione fra i vari key points.

i e
- -"'-------
9 .rF""_:-F-
- i 5 !
______.--‘ =
A 4 #___'_.,_.a-"' -
§ (] 12 18 24 n ] 42 4B 56 &0 5B T Ta

Provate I'animazione e noterete una sostanziale differenza nel momento
in cui la pallina rimbalza sul terreno.

Selezionate una delle maniglie della tangente; tramite Move e il tasto
centrale del mouse, spostatela leggermente verso I'alto in modo che
venga ulteriormente modificata la curvatura per il key point selezionato.
Per default spostando una tangente, I'altra verra spostata nell'esatta
opposta direzione.

In questo modo € sempre garantita la simmetria per la curvatura;nel
nostro caso, invece, abbiamo bisogno di interrompere l'interdipendenza
fra le due tangenti.

Ricorriamo quindi ad Undo in modo da annullare il precedente
spostamento;selezionate il key point al frame 50.(non la maniglia della
tangente)

Dal Graph Editor selezionate Keys > Break Tangents.

In questo modo sara possibile spostare ogni tangente in modo
indipendente.

Tradotto e testato da Fabio Cavalo - e-mail : f_cavallo @virgilio.it



MAYA Animazione Tutorial n. 8

Selezionate la maniglia della tangente di destra e tramite Move
spostatela verso |'alto.

Fate la stessa cosa anche per la tangente di sinistra; ponete attenzione
nell'evitare di selezionare il key point.

In questo modo siamo in grado di simulare la gravitazione e I'elasticita
del rimbalzo.
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Tutorial Otto -
Animazione con Maya

Introduzione

Incrementare la velocita dell'animazione

La pallina sembra muoversi troppo lentamente!

Vedremo come aumentare la velocita dell'animazione, sempre tramite il
Graph Editor e nello specifico faremo in modo che la durata completa
sara di soli due secondi (48 frames), rispetto ai tre previsti inizialmente.
(72 frames)

Disegnate una box di selezione intorno a tutti i key points di entrambe le
curve.

Selezionate lo strumento Scale.
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Cliccate (tenendolo poi premuto) con il tasto centrale del mouse su un
punto qualsiasi del Graph Editor al frame 1 (nelle vicinanze alla destra
dello 0). Notate l'icona con il punto di domanda che indica il punto da cui

comincera l'operazione di scalatura. (scaling)

Senza rilasciare il tasto del mouse trascinate verso sinistra, fino a quando

i punti sulla destra saranno posizionati al frame 48. (una volta

selezionati, i punti diventano gialli)
In questo modo abbiamo avvicinato le
curve in modo simmetrico vicino al
frame 1 e I'animazione verra eseguita

dal frame 1 al frame 48. (piuttosto che _

il frame 72)
Ora il movimento della pallina risultera
sicuramente piu veloce.

Ty

12 * 48 B0
4
Allargare la finestra del Graph Editor in modo da avere una visione chiara
e completa.
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Regolare la curva di animazione

Per fare una serie di esperimenti, potreste provare ad aumentare la velocita del
movimento orizzontale della pallina per il primo rimbalzo, ma non per il

secondo.

In ogni caso ricordate di testare I'animazione ogni volta che fate qualsiasi tipo

di sistemazione.

Le due figure seguenti mostrano alcuni esempi di curve modificate; i grafici
sono identici con la differenza che nella seconda figura vengono mostrate

anche le maniglie per manipolare le tangenti.
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Nel caso voleste aggiungere un fotogramma chiave, cliccate sull'icona Add Keys
Tool, selezionate la curva e cliccate nella posizione in cui volete aggiungere un

fotogramma chiave.

Add Keys Tool
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Rimuovere gli static channels e le chiavi in eccesso

Nel momento in cui abbiamo impostato un Set Key per la sfera, Maya ha creato
una serie di fotogrammi chiave per tutti i nodi attributo di trasformazione,
quindi anche per la rotazione sull'asse Z.(mentre in realta a noi interessa solo il
movimento per l'asse X e l'asse Y)

In questo caso i nodi attributo in 'eccesso’, quindi quelli relativi all'asse Z,
prendono il nome di static channels.

Tramite il Graph Editor diventa abbastanza immediato identificare una curva di
questo tipo;considerato che comunque gli static channels rallentano Maya,
potrebbe risultare utile eliminarli ricorrendo all'opzione Edit > Delete All by
Type > Static Channels.

In questo modo vengono eliminati tutti i fotogrammi chiave ritenuti inutili per
tutti gli oggetti della scena;in alternativa e possibile eliminare gli static channel
relativi ad un oggetto tramite Edit > Delete by Type > Static Channels.

Per eliminare dei singoli fotogrammi chiave, basta selezionarli e premere
Delete.
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Fare una preview dell'animazione per migliorarne la velocita e
la qualita

Per poter fare una preview dell'animazione in modo da rendersi conto della
gualita e della velocita del filmato finale, selezionate Window > Playblast.

L'intera animazione verra processata frame per frame e al termine del processo
comparira una finestra per il playback;premendo sul bottone play potrete
visualizzare I'animazione.

Chiudere la finestra una volta che sono stati percepiti gli eventuali accorgimenti
da effettuare, intervenendo direttamente sulla scena.
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Conclusioni

Tramite il Graph Editor & possibile tagliare, copiare, incollare e cancellare
fotogrammi chiave direttamente nel Time Slider, in modo da modificare
I'animazione;basta selezionare un fotogramma chiave posizionato nel Time
Slider, cliccare con il tasto destro del mouse e quindi selezionare |'operazione
che desiderate effettuare dal menu che compare.
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Tutorial Otto -
Animazione con Maya

Impostare la Driven Key

Tramite I'animazione keyframing impostiamo dei fotogrammi chiave per un
determinato valore di attributo, in un momento specifico sulla Time Slider.

Ripetendo questo procedimento con valori di attributo differenti in differenti
momenti, otteniamo I'animazione dell'oggetto.

Con le driven keys, andiamo a creare un fotogramma chiave per un valore di
attributo che punta al valore corrente di un altro attributo;viene quindi creato
un vero e proprio link (collegamento) fra una coppia di attributi.

Cercheremo di rendere I'argomento piu chiaro tramite un esempio
concreto:una porta che si apre al contatto con una palla che rotola.

The ball's translation
towards the door drives the
door's upward translation.
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Impostiamo il playback range e creiamo gli oggetti

1
Creare una nuova scena

2
Posizionatevi al frame iniziale

3
Create un cubo poligonale e chiamatelo Door;scalatelo in modo da
ottenere una geometria simile a quella mostrata nella figura precedente.
Allineate quindi la porta all'asse X.

4
Con il mouse sulla vista perspective, premete 5 (Shading > Smooth
Shade).

5

Create una piccola sfera poligonale e chiamatela Ball; scalatela e
posizionatela come mostrato in figura, sulle coordinate 0, 1, 10.

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo @virgilio.it 6



MAYA Animazione Tutorial n. 8

Creare il link fra gli attributi tramite il Set Driven Key

1
Selezionate la porta e quindi Animate > Set Driven Key > Set O,
Comparira la finestra Set Driven Key con la porta nella Driven list.

2 - Driven
Cliccate su translateY;questo & || o
I'attributo per cui creare una driven translateX
key regolata dal movimento della transiatey

ranslateZ

sfera. i

. . scalex
Selezionate la sfera e dalla finestra scala¥

Set Driven Key, cliccate su Load | scaleZ
Driver;la sfera compare nella Driver
list.

Cliccate su translateZ;questo & I'attributo che regolera la driven key per il
movimento della porta; potete impostare una driven key solo se
selezionate un attributo dalla Driver List e nella Driven List.

Dalla finestra Set Driven Key, cliccate su Key. In questo modo verra
impostata una driven key che crea un link fra il valore corrente di
Translate Z per la sfera e il valore corrente di Translate Y per la porta.

In ogni momento in cui la Translate Z della sfera si trovera in questa
posizione, la Translate Y della porta sara nella propria posizione corrente.
Sulla Time Slider non comparira alcuna indicazione relativa alla Driven
Key.

Sposate la sfera nella posizione della porta e spostate la porta sopra la
sfera.
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7
Cliccate su Key.
In questo modo abbiamo impostato un'altra driven key che crea un link
fra il valore corrente di Translate Z della sfera e il valore corrente di
Translate Y per la porta.

8
Spostate la sfera sulla destra della porta e abbassate la porta in modo
che torni nella posizione precedente :

9

Cliccate su Key in modo da impostare un'altra driven key che crea dei
links fra gli attributi;abbiamo quindi impostato tre driven keys che
linkano i valori attirbuto in posizioni differenti.

Maya effettua l'interpolazione fra i valori linkati in modo da generare i
valori relativi compresi tra i fotogrammi chiave.

Se provate ad avviare I'animazione, noterete come la sfera non viene
spostata;questo perche con le driven keys abbiamo solo creato un link
fra un attributo ed un altro.(non esiste quindi il fattore tempo relativo
alla Time Slider)
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Esaminare la curva di animazione relativa alle driven keys

1
Selezionate la porta;per poter visualizzare la curva di animazione
all'interno del Graph Editor & necessario selezionare I'oggetto che
contiene gli attributi driven.

2
Selezionate Window > Animation Editors > Graph Editor.

3

Dal Graph Editor, selezionate View > Frame All.
Verranno evidenziate le attuali driven keys che creano links fra i valori
relativi a TranslateY della porta e i valori relativi a Translate Z della sfera.
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La colonna di numeri sulla sinistra indica i valori degli attributi driven,
mentre la colonna in basso indica i valori degli attributi driver.

Potete chiaramente notare come il valore di Translate Y aumenta in
corrispondenza dell'avvicinarsi allo 0 del valore di Translate Z.
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Tutorial Otto -
Animazione con Maya

Il Path Animation

Tramite il path animation possiamo animare un oggetto lungo un percorso
stabilito da una curva;questa tecnica puo risultare utile per I'animazione di
oggetti tipo treni, aerei ed altro, senza ricorrere all'animazione di tipo
keyframing.
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Apriamo la scena esaminandone i contenuti

Apriamo la scena InstantMaya/Anim/PathAnim.mb.

La scena contiene tre oggetti denominati Train, Desert e Path_curve.
Train € un group node relativo alle superfici che lo
compongono;inizialmente si trova parcheggiato al centro del deserto.
Desert € una primitiva poligonale di tipo plane, mentre Path_curve & una
curva disegnata fra le valli del deserto.

Nel caso voleste disegnarvi una curva per conto vostro selezionate la
superficie, quindi Modify > Make Live, selezionate Create > EP Curve Tool
e create la serie di punti per disegnare la forma che volete dare alla
curva. Una volta terminata la curva, annullate la selezione di tutti gli
oggetti e selezionate Modify > Make Not Live.

o . .~ Path_curve

Nel Playback End Time inserite 480.
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Specificare il percorso e il frame range dell'animazione

1
Posizionatevi all'inizio dell'animazione.
2
Selezionate Path_curve e quindi Display > NURBS Smoothness > Fine.

Nell'Outliner selezionate Train e Path_curve.(tramite Ctrl, in modo da
selezionarli entrambi)

Considerate che se create una curva su una superficie NURBS piuttosto
che una superficie poligonale, la curva comparira nell'Outliner sotto il
nodo shape della superficie. (Selezionate Display > Shapes dal menu
Outliner, quindi cliccate sull'icona sulla sinistra della superficie e del nodo
shape della superficie)

Selezionate Animate > Motion Paths > Attach to Motion Path O.

Nella options window, attivate Start/End e inserite 1 per Start Time e 480
per End Time;cliccate sul bottone Attach.

Start time ed End time indicano quanto impieghera il treno per
completare il percorso lungo la path curve;inoltre start time ed end time
sono visualizzati sugli estremi della curva.

Nel momento in cui clicchiamo sul bottone Attach, il treno si muove verso
I'inizio della curva e piu precisamente verso il primo punto utilizzato
quando abbiamo disegnato la curva.
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Modificare lI'orientamento del treno lungo il percorso

1
Selezionate Train nell'Outliner.

2
Selezionate Display > Component Display > Local Rotation Axes.
In questo modo vengono visualizzate le coordinate locali del treno (del
group node Train);risultera utile guando andremo a sistemare
I'orientamento del treno lungo il percorso.

3
Selezionate Path_curve.

4
Selezionate Window > Attribute Editor quindi cliccate sul tab motionPath1
per visualizzare gli attributi del path animation.

5
Per invertire I'orientamento del treno, selezionate Inverse Front.
Un modo veloce per ottenere un particolare orientamento per un oggetto
e quello di agire sui settaggi relativi alle varie opzioni disponibili. (Follow,
Front Axis, Up Axis, Inverse Axis)

6

Attivate quindi Bank.

Banking & utile per oggetti tipo motociclette, aerei, treni e tutti i veicoli
che sbandano nel momento in cui cambiano direzione velocemente.
Bank Scale indica la magnitudine del tilt, mentre Bank Limit determina il
tilt massimo consentito in fase decrescente.
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Il treno lungo il percorso (path)

1
Selezionate Train dall'Outliner.

2
Selezionate lo strumento Move

3
Premete Insert key in modo da poter spostare il pivot point

4
Spostate verso il basso I'asse Y del pivot;se necessario selezionate
Shading > Wireframe in modo da visualizzare meglio il pivot durante lo
spostamento

5
Testate I'animazione e sistemate il pivot point fino a quando il treno non
rimarra sopra il deserto per l'intera animazione.
Una volta soddisfatti, premete nuovamente Insert key e selezionate lo
strumento Select.

6

Selezionate il treno e quindi Display > Component Display > Local
Rotation Axes.

In questo modo verra disattivata la visualizzazione delle coordinate locali
del treno.
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Modificare la velocita del treno lungo il percorso

1
Andate al frame 280

2
Selezionate Path_curve.

3
Nel Channel Box, cliccate su motionPath1.
Notate il valore di U che controlla la posizione del treno lungo il percorso.
Un valore di 0 equivale al punto iniziale, un valore di 1 al punto finale;un
valore di 0.582 € la posizione relativa al 58% della lunghezza del
percorso.

4
Cliccate con il tasto centrale sul frame 220 nel Time Slider;in questo
modo verra modificata la current time senza modificare la posizione del
treno lungo il percorso.

5

Cliccate U Value nel Channel Box
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Cliccate con il tasto destro sopra U Value e selezionate Key Selected dal
pop-up menu.

In questo modo abbiamo creato un fotogramma chiave al frame 220 con
U Value uguale a 0.582.

Questo significa che abbiamo fatto si che il treno arrivasse in quel punto
del percorso prima rispetto all'animazione originale.

Nella Time Slider troviamo altri due fotogrammi chiave creati
automaticamente quando abbiamo utilizzato Attach;un fotogramma
chiave al frame 1 con U Value uguale a 0 e un fotogramma chiave al
frame 480 con U Value uguale a 1.

Notate come all'interno della scena troviamo i path markers che sono i
numeri vicini alla curva (1, 220 e 480).

Avviate I'animazione in modo da spostare il treno dal path marker 220.

Cliccate il path marker numero 220. (non cliccate sulla curva)
Utilizzate lo strumento Move per spostare il path marker selezionato
vicino all'inizio del percorso :

e

.,__..___ — \’

Quando avviate I'animazione, il treno si muove piu lentamente nella
prima parte del percorso e quindi subisce un'accelerazione per il resto del
tragitto.
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Invertire la corsa del treno e avviare I'animazione ad una
velocita reale

1
Spostate il path marker 220 vicino all'inizio dell'ultima curva che il treno
fara nel deserto.

2
Posizionatevi all'inizio dell'animazione e avviatela in modo che il treno si
sposti in una posizione vicino al marker 220.

3
Cliccate con il tasto centrale sul frame 300;in questo modo verra
modificata la current time senza modificare la posizione del treno sul
percorso.

4
Nel Channel Box cliccate su motionPathl e quindi cliccate su U Value in
modo da selezionarlo.

5
Cliccate con il tasto destro su U Value e selezionate Key Selected dal
pop-up menu.
In questo modo creiamo un fotogramma chiave al frame 300 per un
valore di U equivalente a 0.56.
Quando avviamo l'animazione, il treno arrivera al marker 220, quindi
invertira la direzione al marker 300 e invertira nuovamente la direzione
arrivando alla fine del percorso.

6

Per visualizzare la preview dell'animazione in maniera piu accurata,
selezionate Window > Playblast.

Eventualmente nascondete la selezione della curva, selezionando
Path_curve e quindi Display > Hide > Hide Selection.
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Tutorial Otto -
Animazione con Maya

Il Trax Editor

Il Trax Editor vi permette di posizionare, scalare, rendere cicliche e mixare le
animazioni, tramite delle clips.

Le clips possono essere parti di un'animazione, animazioni o motion capture.
Se ad esempio io avessi un treno che si scontra con una macchina, potrei

lavorare su due clips differenti (una per il treno ed una per la macchina) in
modo da regolare ogni dettaglio in maniera indipendente.
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Impostare la scena per una ottenere una migliore
visualizzazione

1
Create una nuova scena.

2
Impostate Start Time e End Time a 0 e 170.

3
Selezionate Window > Settings/Preferences > Preferences.
Cliccate Timeline sotto Settings e impostate Playback Speed a Real-time
[24 fps].

4
Selezionate Panels > Layouts > Two Panes Stacked.

5

Visualizzate la visuale perspective in un panel e Trax Editor nell'altro.
(Per visualizzare il Trax Editor, selezionate Panels > Panel > Trax Editor.)
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Creare il protagonista del set (character set)

Per usare il Trax Editor € necessario creare almeno un character set.

1 ) D g g L
Create una sfera poligonale. > _—
Non importa se applicate o meno la texture alla sfera. — '

e <

2
Con il mouse posizionato nella visuale perspective, premete 5 (per
Shading > Smooth Shade All).

3
Con la sfera selezionata, selezionate gli attributi Translate X e Translate Y
dal Channel Box.

4
Selezionate Character > Create Character Set O.

5
Nella options window, inserite Bouncer nel Name box, attivate From
Channel Box per le opzioni relative al Character Attributes e cliccate sul
bottone Create Character Set.

6

Selezionate Character > Select Character Set Node > Bouncer.

Abbiamo quindi creato e selezionato un character set chiamato Bouncer
che contiene solo gli attributi della sfera Translate X e Translate Y.

I settaggi relativi a From Channel Box indicano che solo gli attributi
selezionati dal Channel Box saranno usati per il character set.

Translate X e Translate Y sono gli unici attributi con cui lavoreremo in
questa lezione.

Dal Channel Box controllate che pSpherel.tx e pSpherel.ty siano gli unici
due attributi nella lista sotto Bouncer.
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Animare gli attributi del character set per un movimento ad
arco della sfera

Posizionatevi all'inizio dell'animazione e siate certi che Start Time sia 0 e
non 1.

Con Bouncer nel Channel Box, siate certi che pSpherel.tx e pSpherel.ty
siano settati su 0.

Selezionate Animate > Set Key 0O.

Nella options window, selezionate Edit > Reset Settings e cliccate il
bottone Set Key.

In questo modo abbiamo creato un fotogramma chiave per gli attributi di
Bouncer, pSpherel.tx e pSpherel.ty.

Posizionatevi al frame 20 nella Time Slider.

Inserite questi valori nel Channel Box:
pSpherel.tx: 5
pSpherel.ty: 6

Selezionate Animate > Set Key (oppure premete s) per impostare un
ulteriore fotogramma chiave per gli attributi di Bouncer.
Il Trax Editor visualizza in blue il range dei fotogrammi chiave.

Posizionatevi al frame 40 nella Time Slider.

Inserite questi valori nel Channel Box, quindi impostate un fotogramma
chiave (oppure premete s):

pSpherel.tx: 10

pSpherel.ty: 0
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Avviate I'animazione in modo da visualizzare I'arco lungo l'asse X.
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Creare una clip per I'animazione

1
Nel Trax Editor (il pannello sotto la visuale perspective), selezionate
Create > Clip O.

2
Nella options window, inserite Arc per Name e cliccate Create Clip.
Maya crea una clip per il character selezionato, Bouncer appunto, con il
range di fotogrammi chiave (0-40).
In ogni momento in cui create una clip, Maya rimuove i fotogramma
chiave indicati in rosso sulla Time Slider e li mette nella clip.
Nonostante i fotogrammi chiave non siano piu relativi a Bouncer,
I'animazione rimane la stessa appunto perche la clip viene applicata al
character set per il quale erano stati creati i fotogrammi chiave.
Maya posiziona la clip in una traccia vicino al character da cui e stata
creata;la traccia € solo uno slot necessario per posizionare le clips di
animazione.
La clip viene rappresentata tramite una barra che indica il frame range
della clip stessa;nel momento in cui clicchiamo sulla clip, questa diventa
gialla.
File Edi Modly Creste View Opliors Panels
- EEF-T

'ﬁ- Bounces o pun a0
!
(24 | 53

Se la clip e troppo piccola e non riuscite a leggerne il nome, selezionate
View > Frame All.
Nel caso voleste vedere la Time Slider nel Trax Editor, selezionate
View > Frame Timeline Range.

3

Trascinate la clip nella traccia in modo che cominci da una posizione
differente, al frame 20 per esempio.
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4
Nel momento in cui avviate I'animazione dall'inizio, il movimento di
Bouncer viene ritardato fino al frame 20.

Vi renderete conto che tramite le clips nel Trax Editor posso regolare a
mio piacimento l'inizio di un'animazione come meglio credo.

5

Riportate la clip al frame 0.
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Tutorial Otto -
Animazione con Maya

Modificare il movimento tramite una nuova clip

La modifica del movimento tramite una nuova clip, viene chiamata motion
warping,; attualmente Bouncer compie un movimento ad arco dal frame 0 al
frame 40.

Vedremo come inserire una nuova clip in modo da rendere I'animazione
maggiormente versatile e modificare il range dei frames (da 10 a 30).

1
Selezionate Character > Select Character Set Node > Bouncer.

2
Al frame 10 e 30, impostate un fotogramma chiave con i valori attuali.
(limitatevi quindi a creare due fotogrammi chiave)

3
Al frame 20 impostate pSpherel.ty a 2, quindi create un fotogramma
chiave. Nel momento in cui avviate I'animazione, il movimento ad arco di
Bouncer subira un abbassamento dal frame
10 al frame 30.

4

Con il Trax Editor, selezionate Create > Clip FEEr
Nella options window, inserite Dip per

Name, quindi cliccate su Create Clip.

Maya crea una nuova clip, Dip, per il range di fotogrammi chiave da 10 a
30.

Sappiate che tramite la options window avete anche la possibilita di
specificare un range parziale di fotogrammi chiave dalla Time Slied.
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Cliccate la clip Dip in modo da selezionarla.

o | 3

Con la clip Dip selezionata, selezionate Modify > Enable/Disable.
Nel momento in cui avviamo |'animazione, Bouncer tornera al movimento
originale.(la flessibilita dell'animazione & garantita)

Selezionate Modify > Enable/Disable in modo da abilitare la clip Dip.

Selezionate la clip Arc e disabilitatela tramite Modify > Enable/Disable.
Nel momento in cui avviamo I'animazione, Bouncer si muove
'meccanicamente’ su e giu.

Dovrebbe essere chiaro che ora il movimento di Bouncer viene
influenzato esclusivamente dalla clip Dip.(quindi dall'abbassamento dal
frame 10 al frame 30)

Selezionate Modify > Enable/Disable in modo che venga nuovamente
combinata la clip di Arc con la clip Dip.
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Fondere le clips ed editare gli attributi della clip risultante

1
Selezionate le due clips. (cliccate su una, quindi con shift-click sull'altra)
2
Dal panel Trax Editor, selezionate Edit > Merge O.
Nella Options window, inserite ArcWithDip come Name, quindi cliccate
Merge Clip.
Il Trax Editor sostituisce le clips Arc e Dip con una clip denominata
ArcWithDip1;la clip Arc e la clip Dip sono ancora presenti nella scena,
anche se non le vediamo piu nel Trax Editor.(vedremo anche come
eventualmente recuperarle)
3
Avviate I'animazione e noterete come le clips fuse funzionano
esattamente come le due clip distinte.
4
Fate un doppio click suArcWithDip1l in modo da visualizzare gli attributi
relativi nel Channel Box.
5
Nel Channel Box, inserite 3 per l'attributo Cycle.;quando avviate
I'animazione, Bouncer ripetera il motion di ArcWithDip1 per tre volte.
6
Selezionate View > Frame Timeline Range per visualizzare l'intera clip.
7

Con ArcWithDip1l nel Channel Box, modificate Offset da absolute a
relative.
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8
Avviate I'animazione e noterete quanto abbia influito I'impostazione del
punto 7.
Ricordate che per default, I'Offset € absolute.

9

Impostate Scale a 0.5.

In questo modo viene contratto il time range della clip a 60 frames;
quindi quando avvierete I'animazione Bouncer completera il proprio
movimento in meta tempo rispetto a prima.
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Recuperare una clip precedentemente rimossa dal Trax Editor

1
Nel Trax Editor, selezionate File > Visor.
Ogni volta che create una clip per un character set, anche se non si trova
piu nel Trax Editor Maya la conserva nel Visor.

2
Visualizzate il tab Character Clips del Visor;ci sono tre icone ArcSource,
ArcWithDip e DipSource.
Nel momento in cui creiamo una clip, Maya conserva l'animazione del
character set selezionato in un source clip nel Visor. In realta nel Trax
Editor abbiamo un'istanza della source clip nel Visor; ArcSource,
DipSource e ArcWithDip sono le clips sorgenti (source clips) create
all'interno della scena.

3

Tramite il tasto middle del mouse, spostate ArcSource dal Visor alla
destra della clip ArcWithDip1 nel Trax Editor. Spostate la clip in modo che
cominci dal frame 60.

v-ﬁ-.Em;rw

*-: T
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Nel momento in cui avviate I'animazione, verra avviata ArcWithDip1
seguita da Arc. Considerato che la clip Arc ha il proprio Offset impostato
come absolute, Bouncer saltera alla visuale origine della scena appena
viene avviata la clip Arc al frame 60.
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4
Fate un doppio click sulla clip Arc in modo da visualizzarne gli attributi nel
Channel Box,quindi impostate Offset a relative.
Assicuratevi che Arc (piuttosto che ArcSource) sia visualizzato nel
Channel Box prima di impostare Offset a relative.
Quando avviate I'animazione, vedrete che la clip Arc animera Bouncer
partendo dalla posizione che aveva Bouncer appena terminata la clip
ArcWithDip.

5

Tramite il tasto centrale del mouse, spostate ArcSource dal Visor alla
destra della clip Arc (frame 100) nel Trax Editor. Fate un doppio click
sulla clip Arcl per visualizzarne gli attributi nel Channel Box.

Impostate I'Offset della clip Arcl a relative. (siate certi che Arcl -
piuttosto che ArcSource - sia visualizzato nel Channel Box, prima di
impostare Offset a relative)

Quando avviate I'animazione, Arcl ripete una seconda volta il motion di
Arc.

Le clips Arc e Arcl sono istanze della clip ArcSource; istanziare una clip
consente di ripetere I'animazione delle clips senza ricorrere all'attributo
Cycle.

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo @virgilio.it @



