MAYA Dynamics Tutorial n. 9

Tutorial Nove
Dynamics

Dynamics

Prepariamoci per la lezione

1
Create una nuova scena

2
Selezionate Window > Settings/Preferences > Preferences, quindi cliccate
su Timeline sotto Settings e assicuratevi che Playback Speed sia settato
su Play every frame.
Le dynamics animation funzionano meglio con questo tipo di settaggio.

3

Selezionate quindi Dynamics.

E' possibile creare particelle direttamente cliccando dei punti all'interno della
scena, oppure tramite degli Emitter.(che hanno proprio la funzione di emettere
un determinato numero di particelle)

Per animare le particelle solitamente vengono utilizzati Fields tipo Gravity o
Wind e combinando Emitters, particelle e Fields diventa possibile simulare
fenomeni tipo il fumo, il fuoco o la pioggia.
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Creare un Emitter

delle particelle. Una volta che le particelle vengono generate, le stesse possono
essere controllate tramite i relativi attributi.

Vedremo ora come creare un cerchio e utilizzarlo per emettere delle particelle.

1
Impostate lo start frame a 1 e frame a 75.
3
Selezionate Create > NURBS Primitives Circle O.
Nella options window impostate i seguenti valori e cliccate su Create :
Radius 4
Number of Sections 25
e s e
{\_/)
Con un Radius impostato a 4, il cerchio sara abbastanza grande da farvi
vedere chiaramente |I'emissione delle particelle, mentre con Number of
Sections impostato a 25, I'emissione verra distribuita in modo uniforme.
Per cambiare il colore della griglia (come ad esempio si vede in figura),
cliccate su Display > Grid O.)
4

Con il cerchio selezionato, selezionate Particles > Emit from Object.

Di default verra creato un Omni emitter; nel momento in cui creiamo un
Omni emitter su un oggetto NURBS, ogni vertice di controllo (CV)
dell'oggetto emette particelle in tutte le direzioni.
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Avviate I'animazione in modo da verificare I'emissione delle particelle.

Nel momento in cui creaimo un qualsiasi tipo di emitter, viene creato e
connesso ad esso un particle object.

Una volta avviata I'animazione |'emitter genera particelle e il relativo
particle count viene automaticamente incrementato.

Se torniamo all'inizio dell'animazione, il particle count torna ad essere 0.
Da notare che se avessimo creato un cerchio con un valore basso per
Number of Sections, ci sarebbero stati pochi CVs per il cerchio e quindi
un'evidente distanza fra i punti di emissione delle particelle.

Visualizzate Outliner e selezionate particlel.

Questo e il particle object;il particle object & una collection di particelle
che condividono i medesimi attributi.

E' possibile creare un particle object cge contiene una particella singola o
millioni di particelle.

Gli attributi dei particle objects agiscono sulle caratteristiche delle
particelle emesse e ne controllano la posizione iniziale, la direzione, la
guantita e la velocita.
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Creare un volume axis fields

Tramite il Volume Axis Field € possibile muovere le particelle in differenti
direzioni in base al volume di un cubo, una sfera, un cilindro, un cono o un
toroide.

1
Con il particle object selezionato, selezionate Fields > Volume Axis O.

Impostate i seguenti valori per Volume Axis e cliccate su Create.

Magnitude 50

Volume Shape Cone

Away From Axis 0

Along Axis -1

In questo modo verra creato un Volume Axis Field conico;le particelle si

muoveranno in base all'asse centrale (central axis) relativa al volume.
Per un Cone Volume Shape, il central axis e sull'asse positiva Y :

/

Central Axis

Tramite gli attributi del central axis, possiamo stabilire che le particelle :

muoverle in una direzione approssimativamente parallela agli assi, verso
o distante dal cono (Along Axis)

irradiarle al di fuori o verso l'interno relativo agli assi (Away From Axis)
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creare un effetto turbine intorno agli assi (Around Axis)

si muova in una direzione determinata dalla combinazione di questi tipi di
direzione.

Impostando Along Axis a -1, le particelle si muovono verso il cono. (un
valore positivo farebbe muovere le particelle nella direzione opposta.)
Utilizzando 0O per il valore Away From Axis piuttosto che il valore di
default di 1, le particelle non verranno irradiate in modo distante dagli
assi.

Notate che e possibile utilizzare un valore grande o piccolo per gli
attributi Axis per intensificare o diminuire il movimento delle particelle.
Magnitude specifica la forza del volume axis field;un valore alto esercita
una maggiore forza sulle particelle, piuttosto che il contrario con un
valore basso.

Un buon metodo di apprendimento € sempre quello di fare una serie di
prove con settaggi differenti.

Con Volume Axis Field selezionato, impostate i seguenti valori nel
Channel Box:

Translate Y 13
Rotate Z 180

Scale X 5
Scale Y 13
Scale Z 5

In questo modo il Volume Axis Field viene ruotato e scalato in modo che
vada a combaciare con il particle emitter.

Nonostante il cerchio emetta le particelle verso una direzione casuale, il
Volume Axis Field reindirizzera il movimento verso il cono.
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Posizionatevi all'inizio del playback range e avviate I'animazione per
qualche secondo.

Notate come appena le particelle escono dal cono, andranno nella stessa
direzione ma con un movimento a specchio rispetto all'area del cono.
Nonostante il Volume Axis Field non controlli piu il movimento, le
particelle continuano a muoversi con la stessa velocita e nella stessa
direzione che avevano nel momento in cui sono uscite dal cono.
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Creare un Torus Volume Axis field

1
Selezionate il particle object e quindi Fields > Volume Axis O.

Impostate i seguenti valori per Volume Axis e cliccate su Create.

Magnitude 25
Volume Shape Torus
Section Radius 1.5
Away From Axis -0.7
Around Axis 2

Il Torus Volume Shape creato € molto simile ad una ciambella.
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Un valore di 2 per Around Axis fa in modo che le particelle creano un
turbine lungo la central axis. Per un toroide la central axis € I'anello al
centro della parte solida del toroide.

Un valore di -0.7 per Away From Axis provoca per le particelle un
movimento di tipo radiale verso la central axis.

Nel momento in cui avviamo |'animazione, la combinazione di questi
valori determina un movimento ripetuto (loop) verso Il'alto e verso il
basso, come se lo stesso movimento fosse pilotato lungo la parte interna
del toroide.

E' sempre e solo una questione di prove ripetute fino al raggiungimento
del risultato desiderato;se ad esempio voleste far passare le particelle
attravarso il buco del toroide, basterebbe intervenire su Max Distance e
Attenuation.

Con il Torus Volume Field selezionato, inserite i seguenti valori nel
Channel Box:

Translate Y 15
Scale X 3.6
Scale Y 3.6
Scale Z 3.6

Posizionatevi all'inizio dell'animazione ed avviatela.
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Nella prossima lezione vedremo come sistemare il movimento delle
particelle, dopo che escono dal cono e interagiscono con il toroide.
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Tutorial Nove
Dynamics

Dynamics

Sistemare la velocita delle particelle

Il Torus Volume Axis Field non guida il movimento delle particelle come
avremmo potuto pensare, in quanto il movimento delle particelle viene
determinato dalla velocita iniziale delle stesse particelle. E' possibile ricorrere
all'attributo Conserve per scalare la velocita di emissione e incrementare
I'influenza del Field sul movimento delle particelle.

1
Selezionate |'oggetto particle e impostate I'attributo Conserve a 0.8 nel
Channel Box.
Cambiando il valore di Conserve dal valore di default di 1, abbiamo
diminuito l'influenza della velocita iniziale di emissione sul movimento
delle particelle e aumentato invece l'influenza di Field.

2

Posizionatevi all'inizio del playback range e avviate I'animazione;notate
come ora il movimento delle particelle &€ conforme alla geometria del
Torus Volume Field.
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Impostare il tipo di render

Il particle render type di un oggetto particle stabilisce come le particelle
risulteranno una volta renderizzate.Per esempio, possiamo visualizzare le
particelle come piccole sfere, strisce o immagini 2D (conosciute come sprites)

1
Con l'oggetto particle selezionato, visualizzate I'Attribute Editor e
impostate Particle Render Type a Streak. (scorrete la sezione Render
Attributes)

2

Posizionatevi all'inizio del playback range e avviate I'animazione.

Questo tipo di render (Streak) viene utilizzato per creare meteore o ad
esempio la pioggia.

La lunghezza della striscia (streak, appunto) viene stabilita dalla velocita
delle particelle e quindi se le particelle sono ferme o0 si muovono
lentamente, con un render di tipo Streak non vedrete le particelle.
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Aggiungere i dynamic attributes

Vedremo ora come aggiungere un built-in dynamic attributes all'oggetto
particella;nel momento in cui aggiungiamo un dynamic attribute ad un oggetto,
I'attributo compare nell'Attribute Editor per I'oggetto selezionato.

1

Nel Particle Attribute Editor, cliccate su Add Attributes per il Current
Render Type. Notate gli attributi che vengono aggiunti :

= | Render Attibutes
™ Depth Sort

Pasticle Rendar Type | Stieak

Click here Add Atlioules For

H

Tagrant Randas Tars

[T Coor Accum

Dynamic attributes

Lire Width [1 'l

appear here

Haomal Dir IE g

Tail Fade {0,000 -

Tail Sze |1.IIH:| L

™ Uz Lighting

Impostate i seguenti attributi :

Line

Width 2 setta la larghezza di ogni streak.

. setta I'opacita dello sbiadimento della coda;pud avere un
Tail :

0.5 range da 0 a 1.Un valore di 1 rende la coda opaca, mentre
Fade .
un valore di 0 rende la coda trasparente.

. in questo modo viene scalata la coda. Un valore di 1 € la
Tail ) . :
Size lunghezza di default, un valore inferiore ad 1 rende la coda

piu corta ed un valore superiore ad 1 allunga la coda.
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Aggiungere un attributo 'per particle’

Gli oggetti particle hanno due differenti tipi di attributi : per object e per
particle.

Un per object attribute permette di impostare - tramite un singolo valore - il
valore dell'attributo per tutte le particelle di un oggetto.Ad esempio, un per

object color attribute consente di impostare un colore per tutte le particelle

dell'oggetto.

Un per particle attribute permette di impostare il valore di un attributo per ogni
singola particella dell'oggetto.Ad esempio, il per particle rgbPP attribute
consente di impostare un singolo colore per ogni particella, andando a creare
un vero e proprio array di attributi.(una lista)

Inoltre & possibile impostare dei fotogrammi chiave con i per object attributes.

1

Nell'Attribute Editor, espandete la sezione Add Dynamic Attributes
2

Cliccate sul bottone Color. Verra visualizzato il box Particle Color.
3

Attivate Add Per Particle Attribute e cliccate Add Attribute. Notate come
verra aggiunto |'attributo rgbPP nella sezione Per Particle (Array)
Attributes dell'Attribute Editor.

3 | = Per Pariicie (Array) Attrituites.

1] Add Per Object Attribute | Sosttion

{9 Add Per Particle Attribute rampPosition
ooty R e ]

Shader ey

A acceleration

rampAcceleration

mass
lif sspaneo

TgbPF
FelocityinObjectspace
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Aggiungere colore alle particelle tramite il color ramp

1
Nell'Attribute Editor, cliccate con il tasto destro sul data box rgbPP e

selezionate Create Ramp.

Default color ramp I

age = lifespan
A

v

age=10 >
U (unused)

age =0

Color ramp applied to emitted particles

Notate la corrispondeza progressiva del colore delle particelle, fra lo stato
born / age = 0 / lifespan - die e il relativo colore in direzione verticale
della ramp color (V).

La direzione orizzontale della ramp color (U) non verra utilizzata nel
corso di questa lezione.

Ogni particella cambia il proprio colore dal rosso al verde al blue,
nell'arco del proprio lifespan di 1 secondo (per default lifespan & 1),
dopodiche la particella scompare (dies).

Selezionate Shading > Smooth Shade All. In questo modo potremo
vedere il colore delle particelle quando avvieremo I'animazione.

Posizionatevi all'inizio del playback range e avviate I'animazione.
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E' necessario aumentare Lifespan, in modo che il ciclo di vita delle
particelle duri piu a lungo.

Impostate Lifespan a 3, posizionatevi all'inizio del playback range e
avviate I'animazione.

Notate come ora le particelle attraversano il cono e in parte anche il
toroide. Le particelle cambiano colore nell'arco di tempo relativo a
born, age e die.
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Hardware render per le particelle

Con il software rendering non € possibile ottenere un render per la maggior
parte dei tipi render previsti con le particelle.(compreso Streak)

Bisogna quindi passare ad un hardware render per le particelle.

Testare il render della scena

1
Selezionare Window > Rendering Editors > Hardware Render Buffer.
2
Nell'Hardware Render Buffer, posizionatevi allo start frame e cliccate sul
bottone play;fermate I'animazione al frame 75.
Non & possibile posizionarsi in un punto qualsiasi della Time Slider e
pensare di vedere il risultato corretto, in quanto Maya calcola
I'animazione delle particelle in modo sequenziale, frame per frame.
3
Nell'Hardware Render Buffer, selezionate
Render > Test Render.
Le strisce appaiono piu morbide rispetto a quanto
non lo fosse nella visuale della scena.
4

Sempre dalla finestra Hardware Render Buffer,
seleazionate Render > Attributes.
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5
Nella sezione Attribute Editor's Render Mode, attivate Line Smoothing; in
guesto modo il render Strike verra ulteriormente ammorbidito. (questa
opzione € valida sia per un render Streak che un render MultiStreak)

6

Selezionate ora Render > Test Render.

Fate attenzione percheé se cliccate nella finestra Hardware Render Buffer,
il render scomparira;in questo caso, selezionate nuovamente

Render > Test Render.
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Fare il render di tutta la sequenza dei frames e visualizzare il risultato

1

Nella finestra Hardware Render Buffer, selezionate Render > Attributes
ed editate gli attribute settings come segue :

Questo sara il nome del file che verra creato quando

Filename Emit . .
eseguiremo il render

Start

1 Viene specificato il primo frame dell'Hardware Render
Frame

End Frame 75 Viene specificato l'ultimo frame dell'Hardware Render

Altri attributi nell'Attribute Editor specificano la risoluzione dell'immagine,
il formato del file, l'illuminazione e altre caratteristiche relative al render.

Assicuratevi che nessun'altra finestra sovrapponga I'Hardware Render
Buffer;nel momento in cui effettuiamo un hardware render su disco di
una sequenza di frame, Maya renderizza tutto quanto € compreso nei
bordi della finestra Hardware Render Buffer.

Dalla finestra Hardware Render Buffer, selezionate Render > Render
Sequence;verranno create una serie di files nominati Emit.0001,
Emit.0002, ecc, fino a Emit.0075. Questi files sono singoli render per
ogni frame e verranno salvati nella cartella images del progetto.

Per avviare la hardware-rendered sequence, selezionate Flipbooks >
Emit.1-75.

Chiudete la finestra Fcheck quando avrete terminato di guardare ed
esaminare |'animazione.
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Tutorial Nove
Dynamics

Dynamics

Rigid Bodies e Constraints

Un rigid body € una superficie poligonale o NURBS convertita.

A differenza delle superfici convenzionali, durante le animazioni i rigid bodies si
scontrano l'uno con l'altro, piuttosto che passare |I'uno attraverso l'altro.

Per animare il rigid body motion possiamo utilizzare i Fields, i fotogrammi
chiave, le expressions, i rigid body constraints o le collisioni con particelle o
altri rigid bodies.

I rigid body constraints limitano il movimento dei rigid bodies (il rigid body
motion);i constraints simulano il comportamento di elementi tipo barriere,
chiodi, cardini, ecc.
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Creare la geometria

E' possibile creare rigid bodies dalle superfici NURBS o poligonali.

1
Impostate lo Start Frame a 1 e End Frame a 200.
2
Selezionate Create > Polygon Primitives > Cube O.
3
Nella finestra Polygon Cube Options, utilizzate le opzioni seguenti e
cliccate su Create :
Width 2
Height 4
Depth 0.25
AXxis Z
4
Con il poligono ancora selezionato, selezionate Edit > Duplicate O.
6

Nella finestra Duplicate Options, selezionate Edit Reset
Settings, quindi utilizzate le seguenti opzioni e cliccate su
Duplicate.

Translate 0,3,0

Number of copies 5

In questo modo vengono create cinque copie del poligono,
ognuno posizionato sotto I'altro con una distanza di 3
units.
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Posizionare le geometrie

Posizionate le geometrie come mostrato in figura;tramite il Channel Box potete
inserite i valori che trovate nella tabella sotto la figura, in modo da avere un
posizionamento praticamente identico a quanto illustrato.

| o — — |
—_— = =]
pCubel Translate Z 0
pCube?2 Translate Z 2
pCube3 Translate Z 0
pCube4 Translate Z 2
pCube5 Translate Z -1
pCubeb Translate Z 1
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Creare un Hinge constraints

Un Hinge constraint forza il movimento di un rigid bodies lungo un determinato
asse. Possiamo utilizzare un Hinge constraint per creare I'effetto di una porta
sul cardine, la connessione fra i vagoni di un treno oppure il pendolo di un
orologio.

1
Selezionate Soft/Rigid Bodies > Create Constraint O.
2
Nella finestra Constraint Options, impostate le seguenti opzioni :
Constraint Type Hinge
Initial Orientation
X 0
Y 90
Z 0
Per default I'orientamento iniziale & 0, 0, 0 che orienta I'hinge constraint
parallelamente all'asse Z.
Impostando 90 per I'asse Y, I'hinge constraint viene ruotato di 90 gradi
sull'asse Y e quindi il constraint viene orientato parallelamente all'asse X.
Constraint
i e e
é i J
Per default I'hinge constraint viene creato nel centro della massa del rigid
body.
3

Selezionate pCubel e cliccate Apply;ripetete la stessa operazione per
tutti i poligoni creati in precedenza.
Chiudete la finestra delle opzioni di Constraint.
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Aggiungere una sfera e la gravita

1
Selezionate Create > Polygon Primitives> Sphere O,
2
Impostate Radius a 0.3 e cliccate su Create.
3
Nel Channel Box, impostate Translate Y per Sphere a 18.
4
Con la sfera selezionata, selezionate Fields > Gravity.
Nel momento in cui connettiamo Gravity alla sfera, automaticamente la
sfera diventa un rigid body attivo.
Gli effetti di Gravity influiscono solo sugli oggetti che sono stati
selezionati nel momento in cui aggiungiamo il Gravity field.
5

Avviamo |'animazione.
La sfera cade e colpisce i poligoni che ruotano intorno all'hinge constraint
che abbiamo creato in precedenza.
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Modificare un rigid body attivo a passivo

Maya ha due tipi di rigid bodies: attivi e passivi.

Un rigid body attivo non pu0 essere animato tramite i fotogrammi chiave,
mentre invece € possibile impostare fotogrammi chiave per Translate e Rotate

di un rigid body passivo.

Vedremo ora come rendere passivo un rigid body, in particolare il primo
poligono della nostra catena di poligoni.

1
Selezionare pCubel e aprire I'Attribute Editor.

2
Cliccate sul tab rigidBody e visualizzate gli attributi del rigid body.

3
Nella sezione Rigid Body Attributes, disattivate Active in modo da rendere
pCubel un rigid body passivo. Cliccate su Close per chiudere I'Attribute
Editor.

4

Posizionatevi all'inizio del playback range e avviate I'animazione.
Notate come pCubel non reagisce piu all'impatto con la sfera.
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