MAYA Maya - Modellazione Poligonale Tutorial n. 2

Tutorial Due -
Modellazione Poligonale

Introduzione

La modellazione & quel processo atto a creare creature, esseri umani, o
qualsiasi cosa abbiate in testa, che possa arricchire la nostra scena costruita in
Maya.

L'obbiettivo finale & quello di ottenere modelli realistici e convincenti.
Come gia sappiamo, esistono tre tipi di superfici in Maya: poligonali, NURBS e
subdivsion surfaces, ognuna con proprie caratteristiche e vantaggi specifici.

La modellazione poligonale & particolarmente indicata per superfici spigolose,
come ad esempio una gemma, un martello o altro.

Creare un oggetto poligonale € molto semplice: questo tutorial ci permettera di
operare in questa direzione.
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Introduzione al tutorial

Prima di cominciare, cerchiamo di seguire con particolare attenzione queste
indicazioni in modo da non trovarci in difficolta durante I'esecuzione di quanto
indicato nel tutorial:

1
Creare una nuova scena

2
Assicurarsi che Construction History sia attivato: (nel caso fosse
disattivato, sarebbe visibile al di sopra di esso una X evidente).

3
Selezionare Modeling dal menu

4
Assicurarsi che Display > UI Elements > Help Line sia attivato; useremo
la Help Line durante la modellazione

5

Scegliere Window > Settings/Preferences > Preferences.
Impostiamo il livello di Undo a 50 e clicchiamo su Save
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Modelliamo una superficie

Vedremo ora come modellare un martello partendo da un cubo poligonale.
Creare la forma originaria da una primitiva

Creeremo e scaleremo un cubo per dargli la forma di un martello, quindi

useremo Extrude per creare un piccolo box necessario per realizzare la testa
del martello.

1
Selezionare Create > Polygon Primitives > Cube O. Nella finestra delle
opzioni, selezionare Edit > Reset Settings e cliccare su Create.
2
Con il puntatore del mouse nella vista perspective, premere 5
(corrisponde a Shading > Smooth Shade All).
3
Scalare il cubo in modo da renderlo simile, per dimensioni, ad un
martello.
4
Posizionare il cubo come da figura.
5
Cliccare sopra il cubo con il tasto destro e
selezionare Face dal menu marking.
Maya visualizza i poligoni che compongono il
nostro modello (le facce del cubo).
6

Selezionate la prima faccia nella parte alta del martello.(quella che
andremo ad estrudere nel punto 7)

Ogni volta che selezionate una faccia, muovetevi nella visuale in modo da
verificare se avete selezionato la faccia corretta.
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7
Selezionare Edit Polygons > Extrude Face.
Maya crea una nuova faccia nella stessa posizione di quella selezionata
precedentemente. Le maniglie relative allo strumento Extrude funzionano
come quelle gia viste per gli strumenti Move, Scale e Rotate.

8

Tirate leggermente la maniglia blu verso I'alto, in modo da estrudere la
faccia come mostrato in figura. Notate come la freccia blu diventa gialla,
appunto perché selezionata, e come pure verra creata una nuova
superficie a partire dalla faccia selezionata fino al punto in cui si termina
di tirare la maniglia.

Se deselezionate la faccia, le maniglie spariranno. Per farle riapparire
basta scegliere Modify > Transformation Tools > Show Manipulator Tool e
quindi cliccare su polyExtrudeFacen nel Channel Box.
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Creare le punte della testa del martello

Ora divideremo le facce estruse in due parti: in questo modo potremo
modellare le due punte della testa del martello.

1
Selezionare Edit Polygons > Split Polygon Tool.

2
Cliccare in modo da creare un punto cosi come mostrato in figura.(dovete
cliccare proprio sul segmento)

3
Trascinare il punto verso la meta del segmento e se volete essere precisi
controllare I'Help line fino a quando la percentuale non raggiunge un
valore pari a 50; questo significa che vi trovate proprio a meta
segmento.

4

Create un altro punto verso il basso come mostrato in figura, quindi
premete Invio per dividere la faccia in due parti.

Una singola faccia divisa in due faccie
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Cliccate sul cubo con il tasto destro e selezionate Vertex dal marking
menu. Selezionate i vertici sopra e sotto la linea che divide le due facce.
(Se i vertici risultano difficili da visualizzare, premere 4 per selezionare la
modalita wireframe)

Esaminate I'oggetto da diverse angolature per essere certi di non aver
inavvertitamente selezionato altri vertici!

Selezionare e dividere questi vertici

Selezionare Edit Polygons > Split Vertex.

Selezionare le due facce divise (per visualizzare il centro delle facce,
cliccate con il tasto destro sul cubo e selezionate Face dal marking
menu).

Selezionare Edit Polygons > Extrude Face O. Dalla finestra delle opzioni,
inserire 6 per Divisions, quindi cliccare su Extrude Face.

Compariranno le note maniglie.

Ricordiamoci che quando abbiamo selezionato Extrude Face avevamo
cliccato su due facce: in questo modo le maniglie controlleranno
I'estrusione di entrambe le facce.
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Tirate la freccia blu in modo da avere una forma adeguata per la punta
della testa del martello.

Nel momento in cui andremo ad estrudere le facce, la lunghezza della
superficie estrusa sara suddivisa in 6 parti, non piu nella singola
suddivisione iniziale. Con la suddivisione extra, sara piu semplice
effettuare la prossima modifica per le punte della testa del martello.

Spostate la maniglia rossa in modo da spingere verso l'interno le lame e
con la maniglia verde cercate di appiattirle.
Cercate di seguire I'esempio riportato in figura.

Nello step precedente, abbiamo diviso i vertici all'inizio e alla fine della
linea che divideva le due facce. In questo modo abbiamo creato due
vertici addizionali per ogni vertice diviso (in totale sei vertici). I vertici
addizionali si sono resi necessari per creare la distanza fra le due lame;
senza di essi, le due punte sarebbero state una punta singola.

Nel caso avessimo estruso ogni faccia individualmente per creare le due
punte, non sarebbe stato necessario dividere i vertici per creare la
distanza fra le punte: tuttavia sarebbe risultato piu complicato dare alle
due punte le stesse dimensioni!

Quando estrudiamo due o piu facce contemporaneamente, le maniglie
agiscono sulle facce in modo identico, cosi la simmetria € garantita.
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Tutorial Due -
Modellazione Poligonale

Sistemiamo la forma della testa del martello

Adesso proveremo a migliorare la curvatura delle punte della testa del martello
e a suddividerne ulteriormente la maglia poligonale.

Useremo sempre lo strumento extrude; nel caso in cui le maniglie non fossero
visualizzate, selezionate Modify > Transformation Tools > Show Manipulator
Tool e cliccate su polyExtrudeFace2 nel Channel Box.

Cliccare sul cerchio che racchiude le maniglie per visualizzare la maniglia
di rotazione; a questo punto tirate la maniglia circolare verde verso il
basso, in modo da ruotare I'estrusione (cosi come indicato in figura).

Tradotto e testato da Fabio Cavallo - e-mal : f_cavallo @virgilio.it O



MAYA Maya - Modellazione Poligonale Tutorial n. 2

Cliccate con il tasto destro su una parte qualsiasi della superficie e
selezionate Vertex dal marking menu. Ogni suddivisione della punta &
contraddistinta da un gruppo di vertici che la separano dalla suddivisione
adiacente (osservate la figura).

Muovete ognuno di questi gruppi verso il basso, in modo da rendere la
punta a forma di arco (trascinate un gruppo di vertici alla volta).

E' possibile spostare tenendo premuto Shift, in modo da vincolare il
movimento ad un linea immaginaria corrispondente alla direzione

in cui si muove il mouse.

Spostate questi gruppi di
vertici in modo da creare la
forma tipica della punta di un
martello

Due immagini relative alla modifica appena effettuata
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Estrudere la testa del martello

Adesso cercheremo di creare la parte terminale posteriore della testa del
martello, partendo dall'estrusione di una faccia di un poligono.

Selezionare la faccia del poligono posteriore della testa del martello.

Selezionare Edit Polygons > Extrude Face O.

Dalla finestra delle opzioni, settare Divisions a 1 e cliccate Extrude Face.
Muovete la faccia del poligono verso l'esterno e scalate I'estrusione verso
I'interno; per far questo cliccate sopra una maniglia qualsiasi in modo da
far comparire una maniglia generale al centro del poligono estruso;
cliccateci sopra: in questo modo diventera gialla.

Questo ¢ il centro della scalatura (scalatura uniforme).

Trascinate la maniglia centrale verso sinistra per restringere.

Selezionate Edit Polygons > Extrude Face e muovete nuovamente la
faccia del poligono verso |'esterno. Effettuate una scalatura
dell'estrusione verso l'esterno, questa volta allargando la faccia del
poligono.
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Selezionate Edit Polygons > Extrude Face e muovete questa ulteriore
faccia verso I'esterno, mantenendo le dimensioni dell'ultima estrusione.
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Creare la rientranza nella testa del martello

1
Selezionate la faccia al centro della parte alta della testa del martello.

2
Selezionare Edit Polygons > Extrude Face ed effettuare una scalatura
dell'estrusione verso l'interno (scalatura uniforme sugli assi, come quelle
viste precedentemente).

3

Selezionate Edit Polygons > Extrude Face e tirate verso il basso, come
mostrato in figura.
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Restringere l'impugnatura

L'impugnatura del martello e ristretta nella parte alta e alla base; adesso
cercheremo di sistemarla dandole una forma adeguata. Prima di cominciare &
necessario suddividere le facce della superficie relativa all'impugnatura in modo
da ottenere un humero maggiore di vertici su cui lavorare.

Attualmente I'impugnatura ha solo 4 vertici, uno per ogni angolo; in questo
modo €& possibile restringere solo la parte alta e la parte bassa, ma non altre
zone della maniglia. Aumentando la maglia poligonale della maniglia, sara
possibile intervenire dove lo riteniamo piu indicato.

1

Selezionare le facce della maniglia, compresa quella inferiore.

Selezionare Edit Polygons > Subdivide O.

All'interno della finestra delle opzioni, inserire 2 per il Subdivision Levels,
quindi cliccate su Subdivide.

In questo modo abbiamo suddiviso I'impugnatura in diverse facce con i
relativi vertici; il valore da inserire dipende da quello che bisogna fare. In
guesto caso, provando ad inserire, 1 € stato verificato che il numero di
facce non era sufficiente ai fini del nostro intervento.

Se e vero che avremmo potuto utilizzare lo strumento Split Polygons
visto in precedenza, c’e da dire perd che Subdivide & piu semplice da
utilizzare in quanto selezioniamo direttamente la parte su cui vogliamo
che avvenga la suddivisione.

Lo svantaggio e che alla fine potremmo avere un numero di facce e
vertici superiori e inutili rispetto al reale utilizzo che ne potremmo fare.

Il vantaggio dello strumento Split Polygons, invece, & proprio quello che
siamo noi a decidere dove 'tagliare' e quindi prevedere quante facce e
vertici si possono creare. Il risultato &€ che in questo modo otteniamo una
geometria piu semplice da editare e che Maya puo elaborare piu
velocemente.
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Per visualizzare i vertici, cliccare con il tasto destro sul martello e
selezionate Vertex dal marking menu.
Visualizzate il martello in modalita wireframe.

Scalate ogni riga di vertici sul manico, restringendo lo spessore come piu
riterrete idoneo.

Oltre a scalare una riga di vertici, € anche possibile muoverli su e giu
lungo l'impugnatura in modo da modificarne i contorni (piu i vertici sono
vicini fra loro, piu il poligono relativo risulta teso e raggrinzito; viceversa
se allontanati fra loro, la forma del poligono relativo risultera
ammorbidita).

Righe di vertici

Nella prossima lezione, andremo a smussare gli angoli del martello in
modo che risulti pit autentico.

Prima di fare questo, sara necessario regolare la forma del martello,
modificando le estrusioni precedenti o muovendo o scalando i vertici.

Per modificare un'estrusione, € necessario prima selezionare la faccia o le
facce, quindi utilizzare lo strument Modify > Transformation

Tools > Show Manipulator.

Infine, bisogna cliccare ogni polyExtrudeFacen nel Channel Box fino a
quando le maniglie dell'estrusione compaiono per |'estrusione che
desideriamo modificare.
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Tutorial Due -
Modellazione Poligonale

Ammorbidire i bordi e ultime sistemazioni

Proveremo ad ammorbidire (smoothing) i bordi del martello; questa operazione
aggiungera ulteriori vertici, quindi risultera piu complicato selezionarli
successivamente per apportare ulteriori modifiche.

Generalmente € opportuno sistemare la forma il meglio possibile prima di
effettuare lo smoothing per i bordi.

1
Prima di tutto bisogna decidere su quale parte effettuare lo smoothing;
per ogni bordo che intendiamo ammorbidire, selezioniamo le facce che
combaciano con ogni lato. Ad esempio, per ammorbidire tutti i bordi
tranne quelli della testa del martello, selezionare le facce come mostrato
in figura
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Selezionare Polygons > Smooth. Dopo aver effettuato lo smoothing,
potrebbero comparire alcuni vertici in posizioni errate; ad esempio
potreste vedere un vertice debordare dalla base dell'impugnatura
(improper vertex position).

Selezionate qualsiasi vertice posizionato in modo
errato e spostatelo in una posizione che renda la
superficie simmetrica.

Nel caso ci fossero alcuni vertici inutili, potete
tranquillamente cancellarli; se invece voleste
aggiungerli bastera selezionare, come abbiamo gia
visto in precedenza, lo strumento

Edit Polygons > Split Polygons

Improper vertex position

Notate come la parte finale della testa del martello sia eccessivamente
arrotondata. In un martello reale questa forma sarebbe poco credibile!
Selezionate questa parte perche adesso ci lavoreremo

Attivate Snap alla Grids:

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo@virgilio.it Q



MAYA Maya - Modellazione Poligonale Tutorial n. 2

6
Tirate i vertici della testa fino a quando combaceranno con l'asse Y; in
guesto modo i vertici sono sullo stesso piano, pero I'effetto non e proprio
quello desiderato!
Disattivate Snap alla Grids, quindi muovete i vertici indietro nella
posizione desiderata.

7

Modificate la posizione degli altri vertici come meglio credete: insomma,
date vita al vostro martello!

Ricordate che e possibile effettuare ulteriori Smooth, a scapito della
velocita e della flessibilita in fase di modifica, lavorando sui vertici.

Qui sono riportati due esempi di un rendering del nostro martello.
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