MAYA Maya - Luci, ombre e camere Tutorial n. 7

Tutorial Sette -
Settagyi per la scena

Introduzione

Luci, ombre e camere

La conoscenza delle tecniche per il posizionamento delle luci e delle camere &
fondamentale in una scena 3D; uno dei prerequisiti per ottenere un buon
impatto tramite una scena 3D, € quello di esaminare l'illuminazione utilizzata
per i film; nelle prossime lezioni studieremo le tecniche basilari relative a luci,
ombre e camere.
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Creare una luce direzionale

1
Apriamo la scena presente in InstantMaya/Rendering/Lights.mb.
La scena contiene una stanza con due muri e un piano; all'interno della
stanza ci sono un tavolo e una lampada, raggruppate con il nome di
tableGroup. Tutte le superfici dell'oggetto sono per default gray shading.

Nel momento in cui apriamo la scena, Maya illumina la scena con una
luce di default; non esiste un'icona che rappresenti questo tipo di luce:
diciamo che & una luce necessaria quando non ne esiste una della
tipologia prevista con Maya.

Selezioniamo Create > Lights > Directional Light. In questo modo
creiamo una luce al centro della griglia.

Una luce direzionale € simile a quella del sole. I raggi paralleli di questa
luce colpiscono tutti gli oggetti presenti nella scena da una singola
direzione, cosi come viene indicato dalle frecce dell'icona che rappresenta
la luce.

Nel momento in cui creiamo la luce, I'effetto non verra immediatamente
mostrato sulla scena; rimarra quindi attiva la luce di default.
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Selezioniamo Lighting > Use All Lights (Hotkey: 7). In questo modo non
illuminiamo la scena con la luce di default, bensi con le luci create da noi
(nel caso volessimo utilizzare la luce di default, selezionare

Lighting > Use Default Lighting).

Nel momento in cui facciamo un render, Maya utilizza tutte le luci create
dall'utente; se non ci sono luci, Maya ne crea una di tipo direzionale.
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Editare la luce direzionale

Ora vedremo come lavorare sui vari attributi relativi alla luce direzionale creata
in precedenza.

1
Con la luce direzionale selezionata, ruotiamo la luce in varie direzioni:
notate come lo shading della superficie vari a seconda della rotazione
della luce; piu direttamente la luce punta alla superficie, maggiore sara la
lucentezza dello shading.
L'impatto di una luce di tipo direzionale varia a seconda della rotazione e
non della posizione all'interno della scena.

Ruotiamo la luce in questo modo:

Rotate X: -40

Rotate Y: 25

Rotate Z: -20

In questo modo tutti gli oggetti presenti nella scena, vengono illuminati
dalla luce (lo si vede dalla camera view).

Con la luce selezionata, aprite I'Attribute Editor. Provate a variare lo
slider Intensity in modo da verificare gli effetti relativi all'intensita della
luce. Per esempio con un Intensity di 1.6 la luce & talmente intensa che
lo shading grigio appare bianco.
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Dopo il render, il risultato € questo :

4
Nell'Attribute Editor, cliccate sul box bianco relativo a Color box e potrete
scegliere il colore della luce.

5
Selezionate un luce di colore rosso e notate come anche le superfici
subiscono |'impatto della nuova luce.

6

Tornate quindi ad un colore bianco e settate Intensity a 1.2.
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Creare una spotlight

Con Maya abbiamo diversi tipi di luce per simulare luci naturali o artificiali; ora
proveremo a creare una luce di tipo spot.

1
Selezionate Create > Lights > Spotlight. Verra creata una spotlight icon
al centro della griglia.

Muovete la spotlight sopra la lampada. (lungo I'asse Y)

Osservando la spotlight icon da diverse angolazioni, noterete che ha la
forma di un cono con una freccia che punta verso |'esterno.

Il cono rappresenta proprio la luce emessa che si allarga
progressivamente con la distanza!
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Selezionate Modify > Transformation Tools > Show Manipulator Tool.
In questo modo potrete spostare in maniera precisa la luce spotlight.

Eye point

L ook-at point

Il look-at point indica dove la luce viene focalizzata, mentre I'eye point
indica la posizione della sorgente della luce; tutte le luci hanno un eye
point, ma non necessariamente un look-at point.

Spostate il look-at point sopra il tavolo e I'eye point esattamente al
centro della lampada.
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E' possibile anche utilizzare lo strumento Rotate per centrare in maniera
accurata l'eye-point.

Una maniera alternativa per posizionare la spotlight € di selezionare la
luce e quindi Panels > Look Through Selected.

5
Facendo un render, noterete |'effetto della spotlight sia sopra il tavolo
che sul pavimento.
Per default la luce attraversa le superfici e I'ampiezza della spotlight sul
pavimento € superiore, in quanto la dimensione aumenta con
I'aumentare della distanza.

6

Per evitare che la luce attraversi il tavolo, selezionate la luce e aprite
I'Attribute Editor; aprite la relativa sezione Shadows e quindi la sezione
Depth Map Shadow Attributes., quindi attivate Use Depth Map Shadows.
Provate a fare un render, avrete questo risultato :

Attivando Use Depth Map Shadows, la luce della spotlight viene bloccata
dalla prima superficie incontrata (il tavolo, appunto).
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Tutorial Sette -
Settagyi per la scena

Introduzione

Regolare gli effetti della spotlight

Le luci Spot, quelle direzionali e le luci di altro tipo hanno come attributi
Intensity e Color. Vedremo ora alcuni attributi, in particolare quelli relativi alla
luce Sport.

1

Il valore di default per Cone Angle e 40. Dall'Attribute Editor, impostare
Cone Angle a 20. Notate come il cerchio di luce si restringe, mentre con
un Cone Angle di 60 il cerchio di luce ingrandisce.

Questi sono i render con i due valori impostati come specificato :

Cone Angle =20 Cone Angle =60
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Impostare Dropoff a 10. Questo attributo regola la diminuzione
dell'intensita della luce dal centro della regione circolare. Impostare
guesto attributo correttamente € solo una questione di prove; nel
momento in cui incrementiamo Dropoff, I'intensita della luce diminuisce,
quindi € necessario incrementare anche Intensity. Per esempio,
impostando Intensity a 1.6, il render risultera simile a questo :

Cropeff =10 Dropoff = 10
Intensity = 1 Intensity =1.6

E' anche possibile diminuire I'intensita della luce in modo progressivo a
seconda della distanza dalla sorgente; in questo caso € necessario
intervenire su Decay Rate. Di default troveremo No Decay e per la nostra
lezione pud anche andare bene.

Modificando Decay Rate, bisogna agire anche su Intensity.

Impostiamo Penumbra Angle a 10. Questo attributo consente di sfumare
il cerchio di luce; come gia visto in precedenza € necessario fare un po’ di
prove per trovare il settaggio corretto ed & anche possibile impostare
valori negativi:

Penumbra Angle =10 Penumbra Angle =-10
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Nella sezione Light Effects dell'Attribute Editor, cliccate sul bottone a
forma di scacchiera alla destra del box Light Fog.

| Light Effects _
[ Light Fog | =

Esaminate il risultato tramite un render che dovrebbe essere uguale a
questo :

Una volta cliccato sul bottone relativo a Light Fog, Maya crea un nodo di
tipo light fog e visualizza gli attributi relativi nell'Attribute Editor. Color e
Density sono utili per regolare l'intensita e la trasparenza dell'effetto
nebbia.

All'interno della scena compare anche un'icona Light Fog relativa alla
spotlight icon.

Light Fog icon

Questa icona illustra la zona che verra potenzialmente illuminata e noi
possiamo utilizzare lo strumento Scale per espandere o contrarre la zona
di illuminazione.
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Creare le ombre

Ora vedremo come si pud creare un'ombra sul pavimento dalla luce di tipo
spotlight. Per fare questo & necessario editare una serie di attributi relativi a
spotlight.

1

Selezionate la spotlight e cliccate sul tab spotLightShapel nell'Attribute
Editor.

Impostare Cone Angle a 105. Quando faremo il render della scena,
noteremo un'ombra sul muro.(Shadow on wall)

Shadow on wall

Depth Map Shadows indica appunto l'algoritmo che utilizza Maya per
produrre le ombre. Non & importante sapere come funziona I'algoritmo,
ma sapere che, per attivare le ombre, bisogna attivare Use Depth Map
Shadows.
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Per ammorbidire I'ombra, aprite la sezione Shadows dell'Attribute Editor
e quindi la sezione Depth Map Shadow Attributes; impostate Dmap
Resolution a 1000. Il risultato del render € questo:

\ Sharpen shadow edges with

Dmap Resolution =1000

Aumentando il Dmap Resolution aumenta anche il tempo di rendering.
Agendo invece sull'attributo Dmap Filter Size, si regola la sfocatura
dell'ombra e la qualita dell'ombra stessa;per ottenere ombre convincenti
€ necessario quindi lavorare su questi due attributi: Dmap Resolution e
Dmap Filter Size

Ricordate che i tempi di rendering aumentano con il miglioramento della
gualita delle ombre.
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Tutorial Sette -
Settagyi per la scena

Introduzione

Creare una camera e un frame per la visuale del tavolo

Vedremo ora come creare una camera da aggiungere all'interno della scena!

1
Selezionare Create > Cameras > Camera. In questo modo viene creata
una perspective camera con un'icona al centro della griglia che la
rappresenta.

2

Nel Channel Box, cambiate il nome della camera in myCamera.
Nonostante sia stata creata una nuova camera, continuiamo a vedere la
scena attraverso la camera di default chiamata persp.

Ricordate che l'icona per la camera viene creata solo per le camere
create dall'utente.
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Tramite il Show Manipulator Tool posizionate la camera myCamera come
mostrato in figura:

Con la camera selezionata, lo Show Manipulator Tool si riferisce a due
manipolatori gia visti per la luce: eye point e look-at point. Il look-at
point stabilisce il puntamento della camera, mentre I'eye point stabilisce
la posizione della camera.

E' possibile selezionare una camera tramite View > Select Camera.

Selezionate Panels > Perspective > myCamera per visualizzare la scena
tramite la camera myCamera.

Se la camera view non € simile a quella mostrata in figura, selezionate
ableGroup nell'Outliner e quindi View > Frame Selection. In questo modo
viene centrata la visuale della camera myCamera sul tavolo.

Per tornare alla camera persp, selezionare Panels > Perspective > persp.
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5
Per visualizzare i bordi relativi all'area della quale verra fatto il rendering,
selezionate View > Camera Attribute Editor; nell'Attribute Editor aprite
Display Options e quindi attivate Display Resolution.
Comparira un rettangolo che mostra la parte della scena interessata.

6

Nella sezione Film Back dell'Attribute Editor, inserire 1.1 per Overscan.
Aumentando Overscan, la visuale mostrera piu di quanto verra
effettivamente coinvolto in fase di rendering; questo puo essere utile
quando dobbiamo pianificare diversi movimenti della camera o quando
abbiamo oggetti che si muovono fuori e dentro la visuale.
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Animare il movimento della camera

Vedremo ora come creare alcuni fotogrammi per ottenere una semplice
animazione relativa al movimento della camera.

N.B. Alcuni argomenti saranno piu chiari dopo il tutorial relativo all'animazione

1
Posizionatevi all'inizio del range di playback.

2
Spostate la camera in modo da avere una visuale di myCamera simile a
questa :

3
Con la camera myCamera selezionata, impostate un fotogramma chiave
al primo frame; per impostare un fotogramma chiave, selezionate il
menu Animation e quindi Animate > Set Key.

4

Posizionatevi al frame 150.
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5
Ora spostate la camera myCamera in modo da avere una visuale simile a
questa :

6
Impostate un altro fotogramma chiave.

7

Avviate I'animazione, in modo da vedere la camera muoversi attorno al
tavolo nell'arco dei primi 150 frames.
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Conclusioni
Luci

Oltre alla luce di tipo spotlight e direzionale, Maya offre altri tipi di luce per
ottenere luci artificiali o naturali; all'interno di una scena possiamo avere un
minimo di due luci fino ad un massimo di dieci, ricordandovi sempre che
maggiore € il numero di luci, maggiori sono anche i tempi di attesa relativi al
rendering.

Cosi come abbiamo creato I'effetto Fog, abbiamo anche la possibilita di creare
altri effetti, tipo Glow, Halo e Lens Flare.
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Ombre

Maya consente di creare due tipi di ombra: Depth Map Shadows e Ray Trace
Shadows. Le luci di tipo Depth Map Shadows sono meno realistiche delle Ray
Trace shadows, ma piu veloci in fase di rendering.

Solitamente le Ray Trace Shadows vengono utilizzate solo quando realmente
necessario, dipende dalla scena che volete creare.
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Camere

Se avete un minimo di esperienza nel mondo della fotografia, avrete
riconosciuto molti degli attributi nell'Attribute Editor; potete tranquillamente
provare a modificarli e verificarne quindi |'effetto con i render.

In caso contrario, non sarebbe una cattiva idea acquistare un libro relativo alle
tecniche di inquadratura fotografica.

Per avere la possibilita di annullare i movimenti applicati alla camera, bisogna
selezionare View > Camera Attribute Editor e nelle Display Options
dell'Attribute Editor, attivare Journal Command.
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