MAYA Maya - Rendering Tutorial n. 6

Tutorial Sei -
Il Rendering

Introduzione

Il Rendering

In generale, il rendering & un processo grazie al quale siamo in grado di
mostrare o visualizzare qualcosa in un determinato modo;nella grafica 3D, il
rendering si riferisce alla creazione di un'immagine ad alta definizione.

Verranno trattati i seguenti argomenti :

Il Rendering di una scena

Assegnare le superfici ai modelli
In questo tutorial ci saranno riferimenti anche all'animazione, argomento che
verra comunque trattato con un tutorial dedicato.

Prima di cominciare, selezioniamo Rendering dal menu in alto a sinistra. (quello
con le varie modalita di lavoro disponibili)
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Rendering di una scena
Apriamo una scena per testare il rendering

1
Aprite la scena nominata RenderIntro.mb.
Il file si trova nella cartella dove avete installato Maya.
La scena contiene un anello e un'animazione simile ad una moneta che
gira su un tavolo.

In alternativa a questa scena, potete utilizzare una scena creata da voi.
Selezionate Window > Settings/Preferences > Preferences. Cliccate su la
categoria Settings e assicuratevi che I'opzione Time sia settata su Film
(24 fps) in modo che I'animazione risultera di 24 frames al secondo.

Animate la scena per osservare |'animazione.
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Settiamo la superficie dell'anello e del piano su cui poggia

Vedremo ora come si creano i materiali; un materiale € un insieme di attributi
che controllano come appare la superficie, compreso il colore e altri parametri.

La scena RenderIntro.mb visualizza I'anello e il piano in modalita wireframs
(Shading > Wireframe). Questa e la modalita di visualizzazione di default per
gli oggetti all'interno di una scena.

1

Dalla vista perspective view, selezionate Shading > Smooth Shade All
(Hotkey: 5).

In questo modo vengono visualizzati anello e piano in modalita smooth e
con l'illuminazione di default. E' importante attivare la modalita Smooth
Shade All, in modo che potremo visualizzare i materiali che creeremo piu
avanti.

Cliccate con il tasto destro sull'anello e selezionate Materials > Assign
New Material > Blinn. Compaiono gli Attribute Editor per il materiale
Blinn; vedremo in seguito qualcosa in piu sui materiali e sui loro attributi.

Cliccate sul box grigio alla destra di Color.

(| Common Material Al ..c.
i coor (D - 1 -

Qui viene visualizzato il colore scelto.
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4
Cliccate sul I'esagono del colore e trascinate il puntatore verso un color
oro;l'esatto colore non ci interessa, comunque, basta che sia giallo!
5
Cliccate con il tasto destro sul piano e selezionate Materials > Assign New
Material > Lambert.
Compariranno gli Attribute Editor per il materiale Lambert.
6
Cliccate sull'icona a scacchiera, sulla destra dello slider del colore.
.| Common Material Attributes
coor [ ————— ¢/
Viene visualizzata la finestra Create Render Node la quale elenca una
serie di texture che possono essere applicate o connesse al colore del
materiale Lambert e quindi al piano (plane).
7
Cliccate su Cloth.
8

Per avere una visualizzazione in modalita texture, selezionate
Shading > Hardware Texturing (Hotkey: 6).
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Disattivate Display > Grid in modo che non comparira piu la griglia.
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Fra il render di un singolo frame e sistemare i valori della superficie

Vedremo ora quello che viene chiamato software rendering; ossia il processo di
Maya tramite il quale vengono impiegate le risorse hardware per dare vita ai
nostri modelli e creare quindi una scena credibile.

Il software rendering puo durare qualche secondo o qualche ora, dipende dalla
complessita della scena, dai tipi di materiali utilizzati, dalle luci e da un'infinita
di parametri.

Ci sono due modi per fare il software rendering di un frame di un'animazione :

Interactive Photorealistic Rendering (IPR)
render standard di Maya

Ora lavoreremo con IPR; il vantaggio di usare IPR & che abbiamo la possibilita
di verificare immediatamente le eventuali modifiche che andremo a fare sui
materiali o sull'illuminazione; solitamente il render standard viene utilizzato per
il rendering finale.

1
Posizioniamoci al primo frame dell'animazione;usando la camera della
visuale perspective, andremo a fare il nostro primo render.

Per visualizzare la zona su cui andremo a fare il nostro render, bisogna
visualizzare l'area inquadrata dalla camera;selezionate View > Camera
Attribute Editor.

Nel Attribute Editor, aprite Display Options e attivate Display Resolution.
Compare un'area rettangolare che indica la zona che verra renderizzata.
Nella sezione Film Back, modificate Attribute Editor e inserite 1.1 per
Overscan.

Incrementando questo valore, le visuali visualizzano la scena piu di
guanto in realta verra renderizzata.

Questo parametro € utile quando magari andate a spostare la camera e
comunque mantenete l'area di rendering ancora completa, senza
cambiare gli attributi della camera dopo averla spostata.
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Con l'area visibile, potete ruotare la camera vicino all'anello e togliendo
dall'inquadratura parte del piano :

320 x 240

persp

Selezionate Render > IPR Render Current Frame.
In questo modo faremo il nostro primo render;questa € l'immagine che
otteniamo :

i Render View P [=]
File View Hender IPR Opbons Display Help
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La visuale del render (Render View), differisce dalla visuale perspective
della scena, nonostante abbiamo usato la stessa camera :

Nella Render View i colori e le texture vengono visualizzati in maniera
accurata.

Lo sfondo della scena & grigio, mentre quello della Render View & nero.
Nella Render View vengono visualizzati solo le superfici dei modelli;la
griglia, le curve NURBS e le maniglie, non vengono invece visualizzate.
La dimensione della Render View non € uguale a quella della scena : non
vengono infatti visualizzati i bordi.

Per riuscire a visualizzarli anche nella Render View, selezionate

View > Show Region Marquee (dal menu della Render View ).

I Rendet View
File View Render IPR Opbon: Display Help

Border of region to
be rendered

La risoluzione di default & 320x240 pixels;in questo modo il render e
molto piu veloce e comunque utile, nonostante le dimensioni, per darci
un'idea di come sara il risultato finale.

Per incrementare la risoluzione, selezionate Options > Render Globals.
Nella sezione Resolution della finestra Render Globals, selezionate
640x480 dal menu a discesa Presets.

Tirate un angolo della Render View in modo da raddoppiare le dimensioni
della finestra;ora selezionate IPR > Redo Previous Render.

L'utilita & intuitiva;potete verificare immediatamente nella finestra IPR,
gli effetti delle modifiche apportate alle superfici, alle texture o
all'illuminazione, senza dover rifare il rendering.
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5
Tracciate una selezione come mostrato in figura :
La parte selezionata verra aggiornata in relazione alle modifiche che
andrete eventualmente ad apportare alle superfici o alle texture.

6

All'interno della scena, cliccate con il tasto destro e selezionate
Materials > Material Attributes per visualizzare I'Attribute Editor relativo
allo shader Blinn.
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Cliccate sul box Color e cambiate il colore in rosso;automaticamente
Maya modifica I'area del rendering e I'anello diventa rosso.

Potete notare che quando spostate la barra del colore, le modifiche
avvengono istantaneamente anche nell'area del rendering.

Note

Se state usando Maya con Windows NT o 2000, verra visualizzata una
finestra di output (Output Window).

Questa finestra € una statistica riepilogativa relativa al software
rendering che potete anche chiudere senza problemi;per adesso non ci
serve sapere a cosa si riferiscono le statistiche.
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Tutorial Sei -
Il Rendering

Assegnare le superfici

Per rendere i nostri modelli simili ad oggetti del mondo reale & necessario
lavorare sulla superficie del nostro modello.(questo procedimento viene
chiamato Shading o Mapping).

Lo shading include il colore, la riflessione, la trasparenza e un'altra serie di
attributi per dare al nostro modello un determinato aspetto. Cercheremo di
creare una superficie adeguata per 'trasformare' una sfera in un'arancia.

In questo caso stiamo proprio parlando di una superficie, come potrebbe essere
il cemento, piuttosto che la vernice o la cartal

Apriamo una scena

Vedremo ora una scena gia creata per poter fare una serie di prove.

1
Aprite la scena InstantMaya/Rendering/ShadeOrange.mb.
Questa scena contiene una sfera modellata per ricordare un'arancia.
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La visuale perspective ha attivati due settaggi; Shading > Smooth Shade
All e Shading > Hardware Texturing che ci permette di verificare le
modifiche apportate alla superficie.

Assegnare un materiale e settare gli attributi di base

Ora cercheremo di creare un materiale e di assegnarlo alla nostra superficie.(la

sfera)

1

Prima di creare un materiale, clicchiamo con il tasto destro sulla sfera e
selezioniamo Materials > Material Attributes. Il materiale di default, che
si chiama Lambert, compare nell'Attribute Editor.

Clicchiamo con il tasto destro sulla sfera e selezioniamo Materials >
Assign New Material > Blinn per creare un nuovo materiale per la sfera.
Gli attributi del nuovo materiale compaiono nell'Attribute Editor.

Un materiale di tipo Blinn assegna alla superficie un aspetto piu
scintillante rispetto al materiale Lambert. Blinn pud essere una buona
scelta per creare una serie di superfici particolari.

Nell'Attribute Editor, cliccate sul box grigio alla destra di Color e aprite il
Color Chooser.

| Common Material Al e

coor QD - . -

Nel Color Chooser, cliccate sull'esagono relativo al colore e tirate il
puntatore verso un'area arancione, come mostrato un figura.

Notate come la sfera assume il colore scelto nel Color Chooser. Inoltre
tirate verso l'alto lo slider alla sinistra dell'esagono per ottenere una
superficie luminosa.

bt "
il Color Chooszer

IH | TN
[ HNN [
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Cliccate su Accept per chiudere il Color Chooser.

Se confrontate il colore nel box Color con il colore della sfera nella scena,
noterete qualche differenza.

Il colore che abbiamo scelto in precedenza e solo un aspetto di come
appare la nostra superficie;ci sono altri fattori da considerare, come ad
esempio l'influenza della luce sulla superficie.

Gli attributi principali regolabili per controllare l'influenza della luce, si
trovano nel Common Material Attributes. Uno di questi attributi &
regolato dal settaggio della diffusione (Diffuse setting).

Nell'Attribute Editor, tirate lo slider Diffuse per incrementare il brightness
del colore;in questo modo creiamo l'illusione di un'arancia bright.

Diffuse= 8 Ciffuse = 85

In pratica il settaggio di Diffuse fa apparire una superficie brighter.

Il nome diffuse proviene da una propieta in fisica in base alla quale viene
descritto come la luce spreads dopo che ha colpito una superficie.

Una superficie con un diffusione alta, fa apparire I'oggetto come brighter.
Il Common Material Attributes considera anche altre caratteristiche della
luce e il modo in cui una superficie reagisce alla luce.

La prossima sezione nell'Attribute Editor, lo Specular Shading, contiene
gli attributi che controllano I'apparenza del punto speculare (specular
highlights) di una superficie.
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Modificare lo specular highlights

Ora modificheremo la specularita di una superficie, ossia la quantita di luce che
viene riflessa da una superficie e che prende il nome di punto speculare.

1
Nella sezione Specular Shading dell'Attribute Editor, muoviamo lo slider
Eccentricity indietro e forth per modificare la dimensione del punto
speculare.

2
Muovete lo slider Specular Roll Off per modificare il blend fra la parte
illuminata e le altre zone della superficie.
Modificando questo attributo, non viene alterata la superficie nella visuale
della scena, quindi dovete necessariamente controllare il Material Sample
nell'Attribute Editor (guardate l'illustrazione).
Potete anche fare un render per cerare un'immagine di test
(Render > IPR Render Current Frame).

S a

Specular Shading =

Eccentrichy [0.306 - i -
Specular Fall 08 (0,785 f i | %
Attribute Editor IPR in Render View

Lavorando sui materiali, incontreremo altri attributi che non hanno effetti
immediati nella visuale della scena, per esempio Ambient Color e
Translucence; generalmente & sempre utile fare un render di test.

3
Muovete lo slider Reflectivity per verficare cosa accade.
Ne il Material Sample ne la visuale della scena subiscono cambiamenti!
Modificando Reflectivity e Reflected Color, si potranno verificare gli effetti
solo quando la scena verra settata in modo da avere la riflessione;inoltre
la riflessione non compare neanche con I'IPR renderer ed & necessario
fare un Render > Render Current Frame.
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Cambiare materiale per effettuare confronti

1
Nel Type attribute, in alto nell'Attribute Editor, aprite il menu e
selezionata Phong E.
Phong e Phong E sono variazioni del materiale Lambert, con l'aggiunta
del punto speculare.
Passando da un materiale ad un altro, diventa possibile capire con quale
materiale otteniamo la specularita desiderata.
Il colore e la diffusione vengono comunque mantenuti, perché sono in
comune per tutti i tipi di materiali.
Cambiando il materiale, la specularita ed altri attributi non vengono
convertiti, quindi € meglio scegliere il materiale prima di farci ogni tipo di
modifica.

2
Nella sezione Specular Shading, lasciate Roughness e Highlight Size al
settaggio di default;in questo modo otteniamo una arancia con un waxy
look.
Questi attributi sono simili agli attributi Blinn, Eccentricity e Specular Roll
Off;le verifiche delle modifiche possono essere verificate con il Material
Sample o con un render.

3

Il materiale Phong E ha un attributo Whiteness che non € disponibile con
Blinn. Modificate Whiteness verso una luce grigia per accentuare il punto
speculare.

Provate ora a tirare lo slider avanti e indietro, verificando I'effetto nel
Material Sample o nella IPR region.
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Assegnare una texture

Una texture, in Maya, € una insieme di attributi che servono per creare i
dettagli di una superficie.

Una texture viene anche chiamata texture node; un node & una collezione di

attributi (o azioni) con una unica finalita.(allo stesso modo potremmo avere
anche uno shader node oppure un material node).

Per visualizzare una texture su una superficie, applicheremo un nodo texture
ad un attributo del materiale della superficie; ora assegneremo una texture
all'attributo Color per il materiale Phong E.

1

Cliccate l'icona a forma di scacchiera vicino alla slider Color.(questo
procedimento viene anche chiamato mapping di una texture).

1(F

i Create Rendo Nodn

Dgbions Melp
Matends  Tenturmt | Lighus | Uities |
F 'with Hew Tastas Placemsnt =
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o ot |
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!Il-n— loim
Broe W

d ' -

e |

La finestra Create Render Node visualizza un elenco di texture che si
possono utilizzare.

Il nome della texture e l'icona relativa ci aiutano a capire che tipo di
texture scegliere!
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2
Prima di creare la texture, assicuriamoci che dalle opzioni sopra lo
swatchs texture sia selezionato Normal.
L'opzione Normal significa che Maya 'spalmera’ la texture intorno alla
superficie;gli atri possibili settaggi - Projection e Stencil - sono altri modi
di applicare la texture.

3
Cliccate sul bottone File texture;comparira il nodo filel nell'Attribute
Editor.
Noterete come all'interno della scena la sfera e diventata bianca, mentre
nella visuale di render e diventata nera.

4
Cliccate sull'icona alla destra dell'attributo Image Name;si aprira il
consueto browser window. (sarebbe il sourceimages)

5

Posizionatevi nella directory InstantMaya/Rendering e aprite il file
mayakist.iff.
Il file texture con un logo Mayakist apparira sulla sfera.
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6

Nell'Attribute Editor, cliccate sul tab place2dTexturel.
fibel

I ]plam?dTaﬁ:nll |
Il tab place2dTexturel € un nodo con una serie di attributi che
controllano la posizione della texture sulla superficie.
Nel caso selezionaste un altro oggetto e I'Attribute Editor non visualizza
piu gli attributi del file texture, per ripristinare la funzione di
visualizzazione, seguite queste indicazioni : cliccate con il tasto destro
sulla sfera, selezionate Materials > Material Attributes e cliccate l'icona
texture map vicino a Color.

7

Provate a muovere verso destra lo slide Rotate UV, vicino ad un valore di
5.9; in questo modo viene ruotato il logo Mayakist sulla superficie.
Questo & stato un caso molto semplice, ma ci sono anche delle situazioni
che richiedono un notevole lavoro di 'calibratura’ della texture!
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Tutorial Sei -
Il Rendering

Assegnare le superfici

Monitorare il lavoro con l'editor Maya Hypershade

Dopo aver creato un nodo texture, sarebbe utile poter modificare anche il
relativo nodo materiale;considerato che i nodi materiale e texture non hanno
icone che li rappresentano all'interno della scena, ricorriamo ad un editor
speciale chiamato Hypershade.

1
Dalla visuale perspective, selezionate Panels > Saved Layouts >
Hypershade/Persp.
Questo layout &€ molto comodo e permette di effettuare il drag and drop
degli elementi dall'Hypershade alla visuale perspective
E' possibile aprire I'Hypershade in una finestra a parte, cosi :
Window > Rendering Editors > Hypershade.

2

Nella parte alta dell'Hypershade, cliccate il tab Materials e assicuratevi
che sia attivato.

Materials | Testures | Utiities | Lights | Camesas | Projects |

Questo tab mostra tutti i materiali presenti all'interno della nostra scena.
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3
Con il tasto centrale del mouse trascinate lambertl nella scena, sulla
sfera;appena rilasciate il tasto, il materiale Lambert compare sulla sfera
al posto del materiale Phong E, creato in precedenza.

4

Adesso trascinate il materiale phongE1 sulla sfera, in modo da ripristinare
il materiale precedente.

Avete appena testato la velocita e la semplicita di utilizzo di una delle
caratteristiche dell'editor Hypershade!
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Selezionate la sfera; dai vari menu all'interno di Hypershade, selezionate
Graph > Graph Materials su Selected Objects.

A questo punto & comparso un grafico nel tab Work Area, nella parte
bassa del menu.

Wark Area | Shader Library |

Questo grafico visualizza tutti i nodi materiale e texture applicati
all'oggetto; mentre il tab Materials € una specie di catalogo dei vostri
materiali, il tab Work Area vi mostra se state lavorando su un nodo
materiale, piuttosto che texture o un altro tipo di nodo.

Osservate come Work Area visualizza delle connessioni verdi fra i vari
nodi;le linee hanno delle frecce che puntano ognuna in un'unica
direzione. Per visualizzare da vicino queste frecce, utilizzate il mouse
nello stesso modo visto per muoversi all'interno della scena.

filel phongE1

Le frecce indicano delle informazioni (di input e di output) interne di
Maya, chiamate connection stream. L'importanza di questa connection
stream la vedremo subito.
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Cliccate sulla linea fra i nodi filel e phongE1 (la linea diventera gialla) e
premete Del sulla tastiera.

La sfera tornera al colore grigio originale, in quanto abbiamo interrotto la
connessione fra i nodi e quindi la texture non & piu assegnata alla sfera.
In questo modo abbiamo dimostrato come sia possibile togliere
I'influenza di una texture su una superficie, senza cancellare la texture.

Selezionate Edit > Undo per ripristinare la connessione che abbiamo
appena cancellato.

Dall'Hypershade, cliccate con il tasto destro sul centro di phongE1l e
selezionate Rename; inserite Orange.

La possibilita di rinominare € una delle tante che abbiamo quando
utilizziamo il menu che appare cliccando con il tasto destro su un
materiale.

Altrettanto utile & Assign Material to Selection;in questo modo possiamo
assegnare |lo stesso materiale ad una serie di oggetti selezionati.
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Creare una texture di bump con Hypershade

Per ottenere la buccia di un'arancia & necessario aggiungere una texture di
bump. Una bump crea l'illusione che la superficie abbia dei rilievi, delle
'rughe’;ricordate, pero, che se osservate di profilo il modello con una texture
bump, noterete subito che la superficie € comunque piatta.(in un render non lo
vedrete MAI, ma all'interno della scena si;ci sono stati dei casi in cui ho fatto
dei render con sole bump procedurali e qualcuno mi ha domandato se avevo
usato I'UV mapping!)

Per creare una texture bump, utilizziamo Create Bar nell'Hypershade.

w Create Textures
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Dalla Create Bar, visualizziamo |'elenco delle 3D Textures.
Il file texture del logo Mayakist € una texture 2D, ora creeremo una
texture 3D.

Con il tasto centrale del mouse, trasciniamo la texture Brownian (sotto
3D Textures) sul materiale Orange nella Work Area tab;rilasciate quindi il
tasto del mouse.

Apparira un menu con un'elenco di attributi relativi al materiale; questi
sono gli attributi comuni per mappare tramite la texture Brownian.

bump map

L'attributo del colore ha il font italics perche gli abbiamo gia assegnato
una texture;di default € possibile assegnare una sola texture per
attributo.

Selezionate bump map dall'elenco degli attributi; Maya applica Brownian
alla mappa di attributi del materiale di bump di Orange.

Sicuramente per effettuare il mapping risulta immediato e semplice
lavorare con un editor di questo tipo, piuttosto che con un editor tipo
I'Attribute Editor.

Creare texture realistiche e qualitativamente valide & solo frutto di
esperienza, test e moltissima pazienza.
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Selezionate Graph > Show Upstream and Downstream per visualizzare la
connessione dei nodi per la nuova texture appena creata.

5
Fate un doppio click su bump3d1 per visualizzarne gli attributi
nell'Attribute Editor.
Questo nodo ¢ il collegamento fra la texture e il materiale:|'attributo piu
importante per il nodo bump3d1 € Bump Depth che controlla I'intensita
della bump.

6

Cambiate Bump Depth a 0.150;vedrete subito diminuire l'influenza della
bump su Orange o sul render.

Nota

Se selezionate Render > IPR Render Current Frame mentre Hypershade &
selezionato, comparira un messaggio : Please select the view you want to
render. A questo punto selezionate la visuale perspective prima di
scegliere IPR Render Current Frame oppure nella finestra Render View,
selezionate IPR > Redo Previous IPR Renderer.
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Torniamo agli attributi della texture brownian1 :

Impostate Increment a 0.3 e Octaves a 4.0

Vi posso garantire che & piu semplice fare prove modificando i vari
attributi, piuttosto che cercare di capire a cosa si riferiscono!
Adesso, perd, sembra proprio un'arancia!
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Tutorial Sei -
Il Rendering

Assegnare le superfici

Modificare il pattern della texture di bump tramite la
trasformazione della stessa

La texture di bump applicata ricorda la superficie della luna (come se fossero
dei crateri) e non & prorprio convincente come arancia!

Le bumps sono troppe e troppo profonde, ma un modo per risolvere questo
problema & quello di scalare l'intera texture.

1
Cliccate su place3dTexturel, alla sinistra di Brownian.
Questo nodo controlla la posizione, la dimensione e la rotazione della
texture. La rappresentazione grafica di questo nodo € un'icona a forma di
cubo che racchiude il nostro modello ed & chiamata texture placement

icon.
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Cliccate il bottone Interactive Placement nell'Attribute
Editor;compariranno le gia note maniglie viste in altre occasioni.

Nella visuale della scena, cliccate su uno dei box di scalatura per attivare
il box centrale di scalatura. Scalate texture placement icon per circa la
meta delle dimensioni originali (fino a quando Scale attribute ha un
valore di 2).

Ora facendo un render, le bumps sulla superficie appariranno meglio
distribuite, ricordando molto piu di prima la buccia di un'arancia.

Before scaling After scaling
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Dopo aver modificato la texture della superficie, tramite la scalatura della
texture, spostate l'icon texture placement al di sopra della sfera.

Notate come nel render le bumps della sfera rimangono identiche!

In questo caso lo spostamento dell'icon texture placement non modifica il
percorso della texture o, piu precisamente, la differenza non si nota con
una superficie tipo quella usata da noi(Brownian)

Le differenze relative allo spostamento dell'icon texture placement si
sarebbero notate maggiormente con una superficie di tipo Marble.

(le venature del marmo sarebbero state riposizionate)

Anche spostare |'oggetto influisce sulla texture della superficie; per
evitare questo inconveniente & necessario imparentare l'icona texture
placement (chiamata anche nodo place3dTexture) all'oggetto.
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