MAYA Maya - Primi Passi Tutorial n. 1

Tutorial Uno
Primi passi con Maya

Introduzione

Il presente tutorial, cosi come quelli che seguiranno, sono frutto di un lavoro di
traduzione e relativo beta testing della guida Istant Maya, liberamente
scaricabile dal sito della Alias presso l'indirizzo :

http://www.alias.com/eng/index.shtml
Nel corso del primo tutorial, modelleremo una porta con maniglia in modo da

introdurre i primi strumenti Maya e capire come funziona questo affascinante
ambiente di lavoro.

Personalmente ho preferito suddividere i tutorials in diverse lezioni, in modo da
rendere piu semplice e pratico l'intero lavoro di apprendimento.
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Cominciamo subito lanciando Maya;notiamo la barra degli strumenti in alto
sullo schermo del monitor :

Cpzioni Generali Dpzioni Animazione
R e
- G 2w s

Fo Edt Modly Cmss Diepiy Window Animsls Dslom Skelston Skn Constisin Characte Help

oo D@ ER®R|Z+&20H v 07 an

Selezione Menl D Lavaro

Clicchiamo nel box dove compare la scritta Animation e selezioniamo Modelling
dalle opzioni disponibili;notiamo subito come le opzioni relative alla
modellazione prendono il posto di quelle relative all'animazione.

La stessa cosa avviene per i relativi box Dynamics e Rendering, mentre le
Opzioni Generali rimangono identiche.

A questo punto selezioniamo Window > Settings/Preferences > Preferences
Ci ritroveremo un menu ricco di opzioni:bene, procediamo.

1)Dalla lista Category sulla sinistra, clicchiamo su Undo e settiamo
Queue Size a 50

In questo modo avremo la possibilita di annullare le ultime 50 operazioni
eseguite durante I'utilizzo di Maya

2)Clicchiamo su Save per salvare le modifiche appena apportate alla
configurazione di Maya

Quando raggiungeremo una certa familiarita con Maya, potrebbe essere utile
diminuire il livello di Undo in modo da rendere |'utilizzo di Maya ancora piu
veloce e performante di quanto gia non lo sia.
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Visto che stiamo per entrare nel mondo di Maya, mi sembra giusto iniziare con
una porta!

Cominceremo con la creazione di un cubo, quindi prenderemo un minimo di
familiarita con la telecamera presente nella scena.

1

Selezioniamo Create > Polygon Primitives > Cube

Il cubo appare nella nostra visuale, che in pratica sarebbe una finestra
nella nostra scena 3D chiamata anche Workspace.

Il cubo & una forma predefinita e come le altre forme predefinite viene
chiamata primitiva (primitive).

Automaticamente Maya centra il cubo intorno all'origine degli assi, il
punto centrale nella scena.

Per avvicinarci al cubo, teniamo premuto A/t e muoviamoci verso destra
con i bottoni left (sinistra) e middle (centrale) del mouse premuti.
Diversamente muovendoci con la medesima combinazione di bottoni
verso sinistra, ci allontaniamo dal cubo.
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Per avere una visuale da un posizione elevata della camera, teniamo
premuto A/t in combinazione con il bottone middle del mouse e
muoviamoci verso destra, sinistra, su o giu con il mouse.

Per avere una visuale dalla griglia, e sufficiente premere Alt € in
combinazione il bottone left del mouse.
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Per primitiva si intende una figura geometrica che pud essere un cubo, una
sfera, un cono, ecc, gia disponibile senza bisogno di costruirla, pronta per
essere utilizzata ed alterata nella forma tramite gli strumenti offerti da Maya.

Le nostre primitive, infatti, sono formate da poligoni che a loro volta sono
formati da vertici (punti);il segreto, quindi, € tutto nel creare le linee (i tagli) in
modo che si possa poi lavorare correttamente sui vertici per dare forma e vita
al nostro modello.(quantomeno con la modellazione poligonale)

Per quanto riguarda il Pivot Point di una primitiva, non € altro che il punto di
riferimento (per Maya e qualsiasi altro software 3D) dei movimenti lineari e di
rotazione.

La maggior parte delle volte € utile centrare il Pivot Point agli assi X, Y e Z
(quindi all'origine 0,0,0);sicuramente in seguito avremo modo di rivedere
meglio questi argomenti.

L'importante & crederci e non lasciarsi prendere dallo scoramento iniziale,
perche tutto potrebbe apparire inarrivabile e troppo complicato.
(quando invece e esattamente il contrario)

Ci sono tre tipi di superfici in Maya : poligonali, NURBS e 'suddivise'
(subdivision surfaces), ognuna con peculiarita differenti e indicata a seconda di
quello che si intende modellare

(ovviamente la capacita di scegliere la modalita corretta, dipende
esclusivamente dall'esperienza nell'utilizzo di Maya)

Per adesso torniamo a lavorare sul cubo avendo modo di apprendere e
migliorare giorno dopo giorno, anche grazie alle lezioni successive.

E' giunto il momento di applicare il primo strumento Maya alla nostra
primitiva;gli strumenti disponibili sono tanti e solo con il passare del tempo si
riuscira a capire come usarli e quando.

In questo caso dobbiamo utilizzare uno strumento per scalare (deformare, per
intenderci) il nostro cubo in modo da ottenere una forma che quantomeno
somigli ad una porta.
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Gli strumenti disponibili sono quello di movimento (Move), rotazione (Rotate) e
deformazione (Scale)

1
Provate a muovere il puntatore del mouse sopra una qualsiasi di queste
icone e lasciatelo in posizione fino a quando non vedrete comparire il
nome dello strumento;potrete notare come il nome compare anche nella
Help Line in basso sullo schermo del monitor.

2

Cliccate sull'icona Scale Tool e selezionatela.
Vedrete apparire delle maniglie intorno al cubo
(se le maniglie non dovessero apparire, cliccate su un lato del cubo)

Maniglia relativa allo scale
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Le maniglie puntano agli assi fondamentali nel mondo 3D, ossia X, Ye Z
e controllano la direzione della trasformazione;cliccando su una maniglia
(quella rossa, per esempio) significa che la trasformazione avverra in
quella direzione.

Clicchiamo sulla maniglia verde e trasciniamola verso l'altro, tenendo
premuto fino a quando il cubo non & almeno il doppio dell'altezza
originale.

XYZ sono di colore rosso, verde e blu, in modo da distinguerle
meglio;una volta selezionata un maniglia, questa diventa gialla.

Adesso clicchiamo sulla maniglia blu e trasciniamo fino ad ottenere una
forma adeguata per una porta.

Clicchiamo sulla maniglia centrale e tiriamo verso destra, fino a quando il
cubo ¢ di circa tre volte piu largo.Se necessario utilizzate la camera per
muoversi nella visuale e capire meglio come state lavorando.

Tirando la maniglia centrale in ogni direzione, verranno mantenute le
proporzioni create nello step precedente.
(scalatura uniforme)
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Ora selezioniamo l'icona Move. Noterete subito che le maniglie cambiano
forma e diventano frecce

Maniglie relative a Move

Spostate il cubo fino a quando la parte inferiore € allineata con la griglia,
considerando la griglia come un vero e proprio piano di lavoro.

Nella prossima lezione, andremo avanti con la modellazione della porta;
nel frattempo esercitatevi e in particolare cercate di arrivare almeno fino
a questo punto in modo autonomo;potrete cosi familiarizzare prima con il
programma e assimilare in maniera esaustiva l'intera lezione.

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo@virgilio.it o



MAYA Maya - Primi Passi Tutorial n. 1

Strumenti di lavoro

Utilizzare la visuale frontale per posizionare il cubo in modo
appropriato

Vedremo ora come utilizzare altre visuali che risultano piu semplici per il
posizionamento del cubo sulla griglia.

1
Dal menu sopra la scena, selezionare Panels > Layouts > Four Panes.
E' possibile dividere il workspace in due, tre o quattro visuali;la visuale
prospettica (perspective) e le visuali ortografiche (orthographic - top,
front e side);questa € la classica impostazione 3D del layout.

2
Dalla visuale front posizionate la camera vicino al cubo;ricordate che sara
possibile ruotare in ogni direzione la camera solo nella visuale
perspective.

3

Per ingrandire una visuale, in questo caso la visuale front, posizionate

il puntatore del mouse sopra la visuale front e premete velocemente la
barra spaziatrice.(questa regola & valida per ogni visuale)

Tenendo premuta la barra spaziatrice, invece, verra attivato un menu

chiamato Hotbox, argomento trattato al termine di questo tutorial.
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4
Allineate la parte bassa del cubo con la linea nera centrale della griglia,
cosi come illustrato nella seguente figura :
In generale la visuale ortografica aiuta nel posizionamento e per la
selezione del modello.

5
Premiamo nuovamente la barra spaziatrice e torniamo alla visuale con
quattro pannelli.

6

Terminato di muovere il cubo, cliccate sullo strumento Select;in questo
modo eviterete di muovere il cubo involontariamente.

Bottone Hide

Select

Attenzione a non cliccare I'hide button sopra lo strumento Select,
altrimenti il box di strumenti relativo scomparira.

In questo caso, Display > UI Elements > Restore UI elements,
ripristinera la situazione iniziale relativa all'interfaccia utente.

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo@virgilio.it o



MAYA Maya - Primi Passi Tutorial n. 1

Creare e assegnare un nome ad un oggetto da usare come maniglia
della porta

1

Selezionare Create > NURBS Primitives > Sphere per creare una sfera
NURBS (automaticamente nell'origine della scena).

Maya assegna alla sfera un nome di default, che compare a destra in un
box posto in verticale, chiamato Channel Box.

Channel Box:

Channels  Objsct
nurbsSpheret
Transiate X
Transkale
Transiale I
Fotafe X
Rotate v
Rotals T

5-*-*-*-:-!:.‘-I:II:II:H.:I

In questo caso il nome e nurbsSpherel.

Cliccate sopra il nome e inserite un nuovo nome : Knob.

E' importante assegnare agli oggetti un nome significativo perche molti
strumenti funzionano identificando un oggetto dal nome.(in una scena

con molti oggetti, diventa facile confondersi)

Il Channel Box termina dove comincia il Layer Editor, ma questa parte

non & prevista durante il presente tutorial.
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3
Selezioniamo il cubo cliccandoci sopra e rinominiamolo come Door.
4
Nella visuale perspective, selezioniamo Knob e quindi
View > Frame Selection per effettuare uno zoom.
Notate che la "f" che compare vicino al menu View > Frame, indica una
scorciatoia sulla tastiera, ossia una hotkey.
5

Selezioniamo lo strumento Scale e agendo sulla maniglia Z facciamo in
modo che Knob risulti la meta della profondita iniziale. Ogni visuale ha
un'icona nell'angolo sinistro che indica I'orientamento della
visuale;questa icona & chiamata View Axis.
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Creare e trasformare una base per knob

Adesso creeremo un cilindro che sara la base per la maniglia della
porta;vedremo anche altre caratteristiche del Channel Box e Outliner.

1
Per creare un cilindro , basta cliccare sull'icona del cilindro :
N L9 TOo 9B L knaw
Questo set di icone & chiamato Shelf.
Cliccare sopra l'icona corrisponde al menu item Create > Polygon
Primitives > Cylinder.
Probabilmente utilizzando spesso Maya diventera immediato ricorrere allo
Shelf, piuttosto che al menu.

2
Rinominare pCylinderl come Base.

3
Nel Channel Box inserire 90 come angolo di rotazione per l'asse X (Rotate
X) e premere Invio.
Notare che la rotazione avviene sempre in base al gia citato Pivot Point.
Rotate X € un attributo dell'oggetto Base;sarebbe stato possibile
effettuare la rotazione anche tramite lo strumento Rotate, ma grazie al
Channel Box la rotazione & avvenuta velocemente e soprattutto
esattamente.
Ricordate di premere Invio per rendere effettivi i valori inseriti per i vari
attributi all'interno del Channel Box.

4

Selezionate ora la visuale side e assicuratevi che l'asse Z dell'icona View
Axis punti verso sinistra, come in figura :

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo@virgilio.it Q



MAYA Maya - Primi Passi Tutorial n. 1

5
Nella visuale perspective utilizzare la maniglia centrale dello strumento
Scale per scalare verso il basso Base, fino a quando combacia con gli
estremi di Knob.
La figura di riferimento illustra come :

6

Muovere Base verso sinistra (usando lo strumento Move), facendo
intersecare una piccola parte con l'oggetto Knob. Non preoccupatevi della
precisione, piuttosto della posizione!

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo@virgilio.it °



MAYA Maya - Primi Passi Tutorial n. 1

7
Selezionare Window > Outliner.
Outliner elenca gli oggetti presenti nella scena e viene spesso usato per
selezionare gli oggetti difficilmente selezionabili all'interno della scena,
come ad esempio gli oggetti sovrapposti.
Per selezionare un oggetto nell'Outliner, basta cliccarci sopra.
Con Shift premuto, inoltre, vengono selezionati gli oggetti adiacenti,
mentre con Ctrl premuto, vengono selezionati gli oggetti non
adiacenti.(uguale alla selezione con Windows)
L'Outliner serve anche per imparentare un oggetto con un altro.
Ogni modifica al padre (traslazione, rotazione e scalatura) viene
automaticamente trasmessa al figlio. Per esempio: se muoviamo un
padre il figlio si muove automaticamente, ma non viceversa; le modifiche
per il figlio non influiscono sul padre.
8
Nell' Outliner, tramite il bottone centrale del mouse, trascinate Base
sopra Knob; in questo modo indichiamo che Knob diventa padre di Base
che ha sua volta diventa il figlio di Knob.(dicesi relazione gerarchica).
Questa terminologia potrebbe apparire alquanto strana, ma scopriremo
che invece e importante stabilire un corretto rapporto di parentela, in
particolare in fase di animazione.
E Knob %
@ defaultLightSet
@ defaulilibactset
Vedremo dopo come trasformare entrambi gli oggetti come una singola
unita.
9

Chiudere Outliner.
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Gostruiamo la porta

Strumenti di lavoro

Modificare la struttura della maniglia

Ora vedremo come lavorare sulla struttura della maniglia per modificarne la
forma.

Prima di tutto cambiamo la visuale, in modo da vedere meglio la superficie
della maniglia.

1 Dalla visuale perspective, selezionare Shading > Smooth Shade All.

La modalita Smooth & molto comoda per rendersi conto di come sara il
modello finale, mentre quella di default, la Wireframe, € utile per
visualizzare e selezionare le varie parti di un oggetto che, in una modalita
differente, sarebbero 'nascoste' dalla superficie dell'oggetto stesso.

Tradotto e testato da Fabio Cavallo - e-mail : f_cavallo@virgilio.it Q



MAYA Maya - Primi Passi Tutorial n. 1

2 Selezionare Door e quindi Display > Hide > Hide Selection, in modo che
venga visualizzata solo la maniglia.
In scene complesse, questa funzione & utilissima!

3 Selezionare quindi Knob e Display > NURBS Smoothness > Fine, in modo
da ottenere una maggior precisione nella visualizzazione di Knob.
Questa operazione serve solo in fase di visualizzazione, in fase di
rendering non € necessaria.
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Editare i componenti di Base

Vedremo ora come sistemare Base laddove essa combacia con Knob;per far
questo dobbiamo intervenire sui vertici dell'oggetto.

1 Dalla visuale laterale, avvicinarsi il piu possibile a Knob e Base.
La visuale side mostra in modo ottimale i vertici e rende piu semplice
editarli;la modalita € ancora di tipo wireframe.

2 Cliccate con il tasto destro sopra il wireframe di Base e selezionate
Vertex dal menu che compare.

Questo menu € un marking menu per la selezione veloce di alcuni tipi di
operazione riguardanti I'oggetto.

3 Tracciate una selezione (diseghando un box) intorno alla colonna di vertici
alla fine di Base, la parte che combacia con Knob.

T e
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4 Selezionate lo strumento Scale e utilizzate la maniglia centrale di scale
per scalare i vertici selezionati precedentemente (ignorare il messaggio
di warning).

Dalla visuale perspective potete controllare come, lavorando sui vertici,
la forma dell'oggetto risulti cambiata.

Altri tipi di superficie hanno differenti componenti, come ad esempio le
superfici NURBS che hanno i vertici di controllo (control vertices - CVs) al
posto dei vertici e funzionano in un modo leggermente differente.

5 Per selezionare l'intero oggetto e quindi abbandonare la visualizzazione
dei vertici, cliccate con il tasto sinistro su Base e scegliete lo strumento
Select.

Noterete come il wireframe di Base assume il colore verde ,rendendo
netta la visualizzazione di un oggetto selezionato; se avete problemi nella
selezione, potete usare tranquillamente Outliner.
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Esaminare gli attributi di Base

Un altro modo per modificare la struttura di un oggetto € quella di lavorare
sugli attributi generati in fase di creazione dell'oggetto stesso.

1 Con Base selezionato, clicchiamo su polyCylinderl all'inizio del Channel
Box. Gli attributi che compaiono, tipo Radius e Height, vengono
automaticamente creati con i settaggi relativi alla forma modellata
dall'utente.

Questi attributi fanno parte della construction history dell'oggetto.
Maya mantiene una construction history nel caso si volessero modificare i
settaggi relativi a questi attributi.

2 Modificate la Subdivisions Axis a 30 e controllate |'effetto relativo nella
visuale perspective.

Subdivisions Axis controlla il numero delle curve che compongono il
cilindro.

Aumentandone il numero, si ammorbidisce ulteriormente la superficie,
ma la si rende anche deformata.

Tale deformazione € dovuta al fatto che abbiamo precedentemente
alterato la forma dell'oggetto muovendone i vertici.

Per non avere questo tipo di problema, evitiamo di far si che il
construction history cambi dopo che abbiamo trasformato o modificato i
vertici di un oggetto (o comunque qualsiasi altro componente
dell'oggetto).

3 Cambiamo la Subdivision Axis con 20 in modo che Base non sia piu
deformata.
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4 Per verificare gli effetti dell'eliminazione della construction history di
Base, selezionate Edit > Delete by Type > History.
In questo modo si ottiene la rimozione degli attributi sotto polyCylinderl.

Il motivo principale dell'eliminazione della construction history & anche un
notevole incremento della velocita della manipolazione degli oggetti, in
particolare di oggetti complessi.

Cancellando la construction history, perd, avremo minori possibilita di
modificare la forma di un oggetto, in quanto dopo la cancellazione non
sara piu possibile modificare i settaggi degli attributi per quell'oggetto.

Questo argomento & particolarmente complesso, perd € importante
sapere che esiste uno strumento di questo tipo e se in futuro diventerete
utenti esperti di Maya, questo discorso acquisira indubbiamente maggior
valore.
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Posizionare la maniglia della porta

Ci preoccuperemo ora di scalare la maniglia e di posizionarla nella corretta
posizione rispetto alla porta.

1  Selezionare Display > Show > Show Last Hidden per far ricomparire la
porta.

2 Selezionare Knob: automaticamente verra selezionato anche Base perché
e legato da relazione gerarchica di tipo figlio.

3 Dalla visuale perspective, scalate verso il basso Knob in tutte le direzioni,
in modo da ridimensionarlo opportunamente in relazione alle dimensioni
della porta.

Per lo stesso motivo di parentela, la trasformazione avviene anche per
Base.

4  Muovete Knob verso I'alto, cosi come mostrato nella figura
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Duplicare la maniglia della porta

Ora vedremo come duplicare gli oggetti con le relative opzioni.

1 Selezioniamo Knob, quindi dal menu Edit selezioniamo I'icona (3) proprio
per duplicare (Duplicate). Apparira una finestra con una serie di opzioni.

I Duplicate Options M=
Edt Help. =
Tranclate |0 0000 00000 {00000
Rolate [0 0000 Jo0000 |0.0000
Seale [1.0000 {1.0000 {1 0000
Nurrbes of Copies [1 J
Geometry Type + Copy " Instance
Group undet * Parent " Wwodd " HewdGioup
[ Smet Tarutom
™ Duplicate Upsheam Giaph
™ Dupicate Input Connections
Duplicats Apph Close

La finestra delle opzioni visualizzata in questo caso € un chiaro esempio
di options window, questo tipo di finestra contiene opzioni relative ad un
altro menu selezionato precedentemente, nel nostro caso

Edit > Duplicate.

E' possibile modificare alcune di queste opzioni all'interno del Channel
Box, ma altre no, come ad esempio il numero delle copie. (Number of
Copies).

E' anche possibile evitare di usare la option windows, basta selezionare
Edit > Duplicate piuttosto che Edit > Duplicate O.

In questo caso verranno tenuti come default gli ultimi valori inseriti
guando si € utilizzato il Duplicate (se non l'avete mai richiamato verra
utilizzato il default).

2 Soffermiamoci su Instance.
Creando un instance, NON creiamo una copia indipendente della
geometria: infatti, modificando la geometria originale, verra modificata
anche l'istance.
Inoltre un oggetto istance utilizza meno memoria di un oggetto copia.
L'unico svantaggio € che non & possibile modificare i componenti
dell'oggetto istance, come i vertici, in modo differente dall'originale.
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3 Cliccate su Duplicate e Maya creera un duplicato chiamato Knob1, nella
stessa posizione dell'originale.

4 Con Knob1 selezionato, modificate Rotate X a -180 e muovetelo nella
parte opposta di Door. La porta € ora completa!

5 Selezionate Edit > Duplicate > O per aprire la options window relativa.
Noterete come |'opzione Instance sia ancora su Geometry Type. Maya
ricorda ogni settaggio impostato precedentemente, in modo che sia
possibile selezionare Edit > Duplicate senza necessariamente utilizzare la

options window.
Fate quindi attenzione, in particolare le prime volte che si usa Mayal!

6 Ora, nella Duplicate options window, selezionate Edit > Reset Settings.
Il Geometry type tornera ad essere Copy che & l'impostazione di default.
Cliccare su Close per chiudere la finestra delle opzioni.

Importante

Il tutorial & stato scritto presupponendo che il settaggio iniziale nella
options window sia rimasto inalterato!

Nel caso si dovessero riscontrare anomalie durante I'esecuzione di un
punto indicato nel tutorial, eseguite un undo e quindi resettate le opzioni
ai valori di default; ripetete quindi la procedura che aveva procurato

anomalie.
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Strumenti di lavoro

Raggruppare le parti della porta

Un modo per modificare la porta potrebbe essere quello di imparentare Door
con Knob e Knob1. Un altro modo & quello di raggruppare gli oggetti.

Un gruppo € come un oggetto invisibile imparentato che verrebbe utilizzato
per gli stessi motivi visti in precedenza:organizzare gli oggetti in una catena
gerarchica e trasformare gli oggetti insieme.

In questo caso imparentare Knob e Knob1 con Door pud anche essere un
metodo di lavoro valido, ma supponiamo di avere 10 porte e che si volessero
muovere come una solal

Piuttosto che imparentare nove porte con una, risulta molto pit semplice
raggrupparle.

1
Dalla vista perspective, Shift-click su Knob, Door e Knob1, in modo da
selezionarli tutti.
2
Selezionare Edit > Group per raggruppare gli oggetti selezionati.
I tre oggetti raggruppati diventano figli di un padre oggetto di tipo
gruppo riscontrabile nell'Outliner, ma invisibile all'interno della scena.
3

Rinominare groupl con DoorGroup.
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4
Cliccare su Door in modo che DoorGroup non venga selezionato.
Come fare per selezionare nuovamente il gruppo ?
Si puo ricorrere all'Outliner, come visto, oppure fare come indicato nel
punto successivo.

5

Premere la freccia verso |'alto per selezionare nuovamente il gruppo
DoorGroup. La freccia verso l'alto sposta la selezione dall'oggetto
corrente al proprio parente.
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Modificare il pivot point della porta

Per consentire una corretta rotazione della porta, in fase di apertura e
chiusura, diventa necessario spostare il pivot point.

Vediamo come :

Con DoorGroup selezionato, selezioniamo lo strumento Rotate.

La maniglia relativa apparira in corrispondenza del pivot point originario.
Se provate a ruotare la porta, noterete che girera su se stessa, in quanto
il perno del movimento € proprio I'origine degli assi.

Premete Insert key sulla tastiera per passare in modalita edit del pivot
point e avvicinatevi in modo da visualizzare meglio la maniglia gialla.

In questo caso pero la maniglia si riferisce al pivot point e non
all'oggetto!

Dalla visuale side, cliccate sulla maniglia rossa (X axis) e spostatela verso
sinistra in modo da allinearla con I'estremita della porta.

Premete nuovamente Insert Key sulla tastiera per uscire dalla modalita
edit del pivot point.
Lo strumento Rotate € ancora attivo.
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Dalla visuale perspective, cliccate sulla maniglia di rotazione e noterete
come il movimento della porta risulta proprio come ci aspettiamo che sia!

Il pivot point influenza sia le operazioni di movimento che di scalatura.
Provate a cliccare lo strumento Move e lo strumento Scale per verificare
che il pivot point & nella stessa posizione per entrambi gli strumenti.

E' possibile modificare il pivot point per ogni singolo strumento, ma per
farlo bisogna introdurre I'Attribute Editor, che verra studiato in seguito.
Un altro strumento molto importante € I'operazione di Center Pivot, nel
menu Modify.

Se per esempio volessimo scalare DoorGroup in tutte le direzioni, una
posizione logica del pivot point sarebbe appunto il centro.
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Visualizzare gli attributi che caratterizzano un oggetto

L'ultima parte di questo tutorial riguarda I'Attribute Editor e il concetto di
nodes.(i nodi)

Selezioniamo DoorGroup, quindi Window > Attribute Editor.

gl Attribute Editor: DooiGrowp

transtom: |[oodGioup 8 | Focus
e |
=] Transform Attributes =]
Translate |0.000 {0,000 Joooo
Ratate 0000 44893  Jooo
Scale [1.000 {1.000 |1.000
Sheat |0.000 j0.000 joooo
Fotate Order | vz =
Riotate A [0.000 Jo.000 Joooo
W Inheits Transfom
] Pivots
- *| Limit Information
| Display

+| Node Behavior
+| Extia Attributes

Select [ Load Altrbutes I Cloge |

Il Channel Box contiene gli attributi maggiormente utilizzati, mentre
I'Attribute Editor contiene tutti gli attributi, alcuni dei quali vengono
utilizzati molto raramente.
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Dalla scena, clicchiamo su Door. L'Attribute Editor visualizza gli attributi
di Door.

gl Attribute Editor: Door I
List Selected Focus Aftbute: Help I

Doot | Docrshape | polyCubet | inialShadingGroup | lambed | l|

MmMm'Mﬂ ?i ﬁnul‘

Gli attributi relativi a Door sono rappresentati tramite dei tabs.

Ogni tab rappresenta un node. (nodo)

Semplificando, diciamo che un nodo € una collezione di attributi e che i
nodi sono interconnessi fra di loro;per adesso questo & sufficiente, ma
facciamo comunque un esempio.

E' possibile connettere I'attributo di rotazione di una sfera ad una
seconda sfera, in modo che la rotazione della prima sfera (output) serve
come input per la seconda sfera.

Il primo tab, Door, viene chiamato transform node.

Ogni oggetto visibile ha un transform node, comprese le camere e le luci.

Clicchiamo su DoorShape tab per vederne i relativi attributi.

Questo tab & chiamato shape node perche gli attributi stabiliscono la
forma geometrica dell'oggetto e le sue proprieta fisiche.

Molti oggetti hanno nodi di tipo shape, ma non tutti, come ad esempio un

gruppo.

Clicchiamo su polyCubel tab per vederne i relativi attributi.

Questo € un nodo di input ed e simile al construction history gia visto per
Base. Il nodo polyCubel non comparira se verra cancellata la
construction history di Door.
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5
Gli ultimi due nodi sono initialShadingGroup e lambertl. Se non riuscite a
vederli, cliccate su la freccia di visualizzazione (Windows)
L
M= £ T Bt
¢ Halp PR
% IR SR ey
adngGioup | e | 4] +] S N et |
Windows UNIX
I nodi initialShadingGroup e lambertl solitamente non vengono utilizzati.
Mavya li utilizza per stabilire il colore iniziale ed altri settaggi relativi alle
superfici. Nel caso dovessimo crearci una superficie per conto nostro,
guesto nodo verra sostituito con il nodo relativo alla superficie da noi
creata.
6

Chiudere I'Attribute Editor.
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Salvare la scena

E' giunto il momento di salvare la scena.

1

Selezionare File > Save Scene As.

Comparira la classica finestra Windows relativa al salvataggio
2

Chiamiamo la scena DoorlLesson.

L'estensione non & necessaria, ci pensera Maya automaticamente.
3

Clicchiamo quindi su Save e Maya salvera il file come DoorLesson.mb.
L'estensione .mb indica che abbiamo salvato la scena come un file
binario, default per le scene Maya.

E' possibile salvare la scena anche in formato ASCII (con estensione
.ma), in modo da modificare direttamente (tramite editor) alcuni comandi
in esso contenuti, piuttosto che usare l'interfaccia di Maya.
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Conclusioni

In quest'ultima parte della lezione, verranno fornite alcune indicazioni
necessarie per proseguire con lo studio di Maya.

C'é ancora tanto da imparare sull'interfaccia, compresi alcuni accorgimenti
necessari per velocizzare I'ambiente di lavoro.

Per esempio un modo per velocizzare la selezione € quello di ricorrere
all'Hotbox (basta posizionarsi in una visuale e tenere premuta la barra
spaziatrice).

O - R

Haothnx Comiods

-
| Skeleton Skin Constrain Characler

Ci ritroviamo il menu principale a portata di mouse!
Una volta visualizzato I'Hotbox € possibile interagire come con ogni altro tipo di
menu disponibile con Maya.
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Organizzazione delle cartelle di lavoro

Nel momento in cui decidiamo di salvare una scena, Maya si preoccupa di
organizzare le scene e gli altri files relativi in una cartella progetto, chiamata
default.

Se provate a visualizzare il contenuto della cartella progetto default, troverete
una serie di cartelle tipo quelle mostrate in figura.

Lok | delaut o &l = )

|1 3PaniTedues ] fuShadowMap (] sound

] data ] images (] sourcemages
|1 futkttiMap | partices i

|| bk qualMap ] rendeD ata

| fuiFiles _J renderScenes

] b mages 1 scenes

La cartella scenes contiene tutte le scene che creiamo con Maya.

In base al tipo di oggetti in essa contenuta, le altre cartelle potrebbero
contenere files relativi alla nostra scena.

Essendo un nuovo utente Maya, non & necessario comprendere il contenuto
delle altre cartelle;in ogni caso sappiate che se vorrete spostare una scena da
una cartella ad un'altra, bisognera stare attenti a muovere l'intero progetto
relativo e non solo la scena.

Spostando l'intero progetto, Maya sara in grado di localizzare tutti i files
utilizzati dalla scena.
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Per salvare la scena in una cartella differente da quella di default:

1
Selezionare File > Project > New.
2
Nel box relativo a Name, inserire un nome esplicativo per la cartella, ad
esempio, my_tutorial.
3
Nel box relativo a Location, indicare un percorso alternativo;e possibile
anche cliccare su Browse.
4
Cliccare su Use Defaults
5
Cliccare su Accept
6

Selezionare File > Save Scene As.
La cartella di default sara quella indicata con i passaggi precedenti.
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